aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-4.14/405-mtd-tp-link-partition-parser.patch
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2018-05-17 18:41:26 +0200
committerJohn Crispin <john@phrozen.org>2018-05-18 09:10:46 +0200
commite2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73 (patch)
tree01d46d7549a9554ff8a659993b97b3d07f5e59f1 /target/linux/ath79/patches-4.14/405-mtd-tp-link-partition-parser.patch
parent12f44b83a8db2c95274839e2e41792e096021f29 (diff)
downloadupstream-e2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73.tar.gz
upstream-e2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73.tar.bz2
upstream-e2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73.zip
kernel: bump 4.14 to 4.14.41
Refreshed all patches Dropped upstreamed patches: 522-PCI-aardvark-fix-logic-in-PCI-configuration-read-write-functions.patch 523-PCI-aardvark-set-PIO_ADDR_LS-correctly-in-advk_pcie_rd_conf.patch 525-PCI-aardvark-use-isr1-instead-of-isr0-interrupt-in-legacy-irq-mode.patch 527-PCI-aardvark-fix-PCIe-max-read-request-size-setting.patch updated patches: 524-PCI-aardvark-set-host-and-device-to-the-same-MAX-payload-size.patch 030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch Added new ARM64 symbol: CONFIG_ARM64_ERRATUM_1024718 Compile-tested on: cns3xxx, imx6, mvebu (arm64), x86_64 Runtime-tested on: cns3xxx, imx6, x86_64 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/ath79/patches-4.14/405-mtd-tp-link-partition-parser.patch')
-rw-r--r--target/linux/ath79/patches-4.14/405-mtd-tp-link-partition-parser.patch12
1 files changed, 4 insertions, 8 deletions
diff --git a/target/linux/ath79/patches-4.14/405-mtd-tp-link-partition-parser.patch b/target/linux/ath79/patches-4.14/405-mtd-tp-link-partition-parser.patch
index 3734d3e5c5..846b7f0a0c 100644
--- a/target/linux/ath79/patches-4.14/405-mtd-tp-link-partition-parser.patch
+++ b/target/linux/ath79/patches-4.14/405-mtd-tp-link-partition-parser.patch
@@ -1,7 +1,5 @@
-Index: linux-4.14.18/drivers/mtd/Kconfig
-===================================================================
---- linux-4.14.18.orig/drivers/mtd/Kconfig
-+++ linux-4.14.18/drivers/mtd/Kconfig
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
@@ -194,6 +194,12 @@ config MTD_MYLOADER_PARTS
You will still need the parsing functions to be called by the driver
for your particular device. It won't happen automatically.
@@ -15,10 +13,8 @@ Index: linux-4.14.18/drivers/mtd/Kconfig
comment "User Modules And Translation Layers"
#
-Index: linux-4.14.18/drivers/mtd/Makefile
-===================================================================
---- linux-4.14.18.orig/drivers/mtd/Makefile
-+++ linux-4.14.18/drivers/mtd/Makefile
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
@@ -18,6 +18,7 @@ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63
obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o