aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-4.14/0026-MIPS-ath79-sanitize-Kconfig-symbols.patch
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2018-05-17 18:41:26 +0200
committerJohn Crispin <john@phrozen.org>2018-05-18 09:10:46 +0200
commite2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73 (patch)
tree01d46d7549a9554ff8a659993b97b3d07f5e59f1 /target/linux/ath79/patches-4.14/0026-MIPS-ath79-sanitize-Kconfig-symbols.patch
parent12f44b83a8db2c95274839e2e41792e096021f29 (diff)
downloadupstream-e2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73.tar.gz
upstream-e2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73.tar.bz2
upstream-e2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73.zip
kernel: bump 4.14 to 4.14.41
Refreshed all patches Dropped upstreamed patches: 522-PCI-aardvark-fix-logic-in-PCI-configuration-read-write-functions.patch 523-PCI-aardvark-set-PIO_ADDR_LS-correctly-in-advk_pcie_rd_conf.patch 525-PCI-aardvark-use-isr1-instead-of-isr0-interrupt-in-legacy-irq-mode.patch 527-PCI-aardvark-fix-PCIe-max-read-request-size-setting.patch updated patches: 524-PCI-aardvark-set-host-and-device-to-the-same-MAX-payload-size.patch 030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch Added new ARM64 symbol: CONFIG_ARM64_ERRATUM_1024718 Compile-tested on: cns3xxx, imx6, mvebu (arm64), x86_64 Runtime-tested on: cns3xxx, imx6, x86_64 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/ath79/patches-4.14/0026-MIPS-ath79-sanitize-Kconfig-symbols.patch')
-rw-r--r--target/linux/ath79/patches-4.14/0026-MIPS-ath79-sanitize-Kconfig-symbols.patch24
1 files changed, 8 insertions, 16 deletions
diff --git a/target/linux/ath79/patches-4.14/0026-MIPS-ath79-sanitize-Kconfig-symbols.patch b/target/linux/ath79/patches-4.14/0026-MIPS-ath79-sanitize-Kconfig-symbols.patch
index 5f41656d1b..f9906516d9 100644
--- a/target/linux/ath79/patches-4.14/0026-MIPS-ath79-sanitize-Kconfig-symbols.patch
+++ b/target/linux/ath79/patches-4.14/0026-MIPS-ath79-sanitize-Kconfig-symbols.patch
@@ -11,10 +11,8 @@ Signed-off-by: John Crispin <john@phrozen.org>
arch/mips/pci/Makefile | 2 +-
4 files changed, 8 insertions(+), 54 deletions(-)
-Index: linux-4.14.18/arch/mips/Kconfig
-===================================================================
---- linux-4.14.18.orig/arch/mips/Kconfig
-+++ linux-4.14.18/arch/mips/Kconfig
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
@@ -203,6 +203,8 @@ config ATH79
select SYS_SUPPORTS_BIG_ENDIAN
select SYS_SUPPORTS_MIPS16
@@ -24,10 +22,8 @@ Index: linux-4.14.18/arch/mips/Kconfig
select USE_OF
help
Support for the Atheros AR71XX/AR724X/AR913X SoCs.
-Index: linux-4.14.18/arch/mips/ath79/Kconfig
-===================================================================
---- linux-4.14.18.orig/arch/mips/ath79/Kconfig
-+++ linux-4.14.18/arch/mips/ath79/Kconfig
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
@@ -1,52 +1,14 @@
# SPDX-License-Identifier: GPL-2.0
if ATH79
@@ -86,10 +82,8 @@ Index: linux-4.14.18/arch/mips/ath79/Kconfig
def_bool n
endif
-Index: linux-4.14.18/arch/mips/ath79/Makefile
-===================================================================
---- linux-4.14.18.orig/arch/mips/ath79/Makefile
-+++ linux-4.14.18/arch/mips/ath79/Makefile
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
@@ -11,13 +11,3 @@
obj-y := prom.o setup.o common.o clock.o
@@ -104,10 +98,8 @@ Index: linux-4.14.18/arch/mips/ath79/Makefile
-obj-$(CONFIG_ATH79_DEV_SPI) += dev-spi.o
-obj-$(CONFIG_ATH79_DEV_USB) += dev-usb.o
-obj-$(CONFIG_ATH79_DEV_WMAC) += dev-wmac.o
-Index: linux-4.14.18/arch/mips/pci/Makefile
-===================================================================
---- linux-4.14.18.orig/arch/mips/pci/Makefile
-+++ linux-4.14.18/arch/mips/pci/Makefile
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
@@ -23,7 +23,7 @@ obj-$(CONFIG_BCM63XX) += pci-bcm63xx.o
ops-bcm63xx.o
obj-$(CONFIG_MIPS_ALCHEMY) += pci-alchemy.o