aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-4.14/0025-MIPS-ath79-drop-irq.c.patch
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2018-05-17 18:41:26 +0200
committerJohn Crispin <john@phrozen.org>2018-05-18 09:10:46 +0200
commite2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73 (patch)
tree01d46d7549a9554ff8a659993b97b3d07f5e59f1 /target/linux/ath79/patches-4.14/0025-MIPS-ath79-drop-irq.c.patch
parent12f44b83a8db2c95274839e2e41792e096021f29 (diff)
downloadupstream-e2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73.tar.gz
upstream-e2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73.tar.bz2
upstream-e2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73.zip
kernel: bump 4.14 to 4.14.41
Refreshed all patches Dropped upstreamed patches: 522-PCI-aardvark-fix-logic-in-PCI-configuration-read-write-functions.patch 523-PCI-aardvark-set-PIO_ADDR_LS-correctly-in-advk_pcie_rd_conf.patch 525-PCI-aardvark-use-isr1-instead-of-isr0-interrupt-in-legacy-irq-mode.patch 527-PCI-aardvark-fix-PCIe-max-read-request-size-setting.patch updated patches: 524-PCI-aardvark-set-host-and-device-to-the-same-MAX-payload-size.patch 030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch Added new ARM64 symbol: CONFIG_ARM64_ERRATUM_1024718 Compile-tested on: cns3xxx, imx6, mvebu (arm64), x86_64 Runtime-tested on: cns3xxx, imx6, x86_64 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/ath79/patches-4.14/0025-MIPS-ath79-drop-irq.c.patch')
-rw-r--r--target/linux/ath79/patches-4.14/0025-MIPS-ath79-drop-irq.c.patch10
1 files changed, 0 insertions, 10 deletions
diff --git a/target/linux/ath79/patches-4.14/0025-MIPS-ath79-drop-irq.c.patch b/target/linux/ath79/patches-4.14/0025-MIPS-ath79-drop-irq.c.patch
index 738f239af0..95b29455f0 100644
--- a/target/linux/ath79/patches-4.14/0025-MIPS-ath79-drop-irq.c.patch
+++ b/target/linux/ath79/patches-4.14/0025-MIPS-ath79-drop-irq.c.patch
@@ -13,8 +13,6 @@ Signed-off-by: John Crispin <john@phrozen.org>
3 files changed, 7 insertions(+), 286 deletions(-)
delete mode 100644 arch/mips/ath79/irq.c
-diff --git a/arch/mips/ath79/Makefile b/arch/mips/ath79/Makefile
-index 783369bc1c5b..bd0c9b8b1b5b 100644
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
@@ -8,7 +8,7 @@
@@ -26,9 +24,6 @@ index 783369bc1c5b..bd0c9b8b1b5b 100644
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
-diff --git a/arch/mips/ath79/irq.c b/arch/mips/ath79/irq.c
-deleted file mode 100644
-index 58d17ef6f58f..000000000000
--- a/arch/mips/ath79/irq.c
+++ /dev/null
@@ -1,285 +0,0 @@
@@ -317,8 +312,6 @@ index 58d17ef6f58f..000000000000
- else if (soc_is_qca956x() || soc_is_tp9343())
- qca956x_irq_init();
-}
-diff --git a/arch/mips/ath79/setup.c b/arch/mips/ath79/setup.c
-index 8d7ffa2e8265..7b089c07d2fa 100644
--- a/arch/mips/ath79/setup.c
+++ b/arch/mips/ath79/setup.c
@@ -19,6 +19,7 @@
@@ -341,6 +334,3 @@ index 8d7ffa2e8265..7b089c07d2fa 100644
static int __init ath79_setup(void)
{
if (mips_machtype == ATH79_MACH_GENERIC_OF)
---
-2.11.0
-