aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-4.14/0022-MIPS-ath79-drop-pci.c.patch
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2018-05-17 18:41:26 +0200
committerJohn Crispin <john@phrozen.org>2018-05-18 09:10:46 +0200
commite2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73 (patch)
tree01d46d7549a9554ff8a659993b97b3d07f5e59f1 /target/linux/ath79/patches-4.14/0022-MIPS-ath79-drop-pci.c.patch
parent12f44b83a8db2c95274839e2e41792e096021f29 (diff)
downloadupstream-e2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73.tar.gz
upstream-e2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73.tar.bz2
upstream-e2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73.zip
kernel: bump 4.14 to 4.14.41
Refreshed all patches Dropped upstreamed patches: 522-PCI-aardvark-fix-logic-in-PCI-configuration-read-write-functions.patch 523-PCI-aardvark-set-PIO_ADDR_LS-correctly-in-advk_pcie_rd_conf.patch 525-PCI-aardvark-use-isr1-instead-of-isr0-interrupt-in-legacy-irq-mode.patch 527-PCI-aardvark-fix-PCIe-max-read-request-size-setting.patch updated patches: 524-PCI-aardvark-set-host-and-device-to-the-same-MAX-payload-size.patch 030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch Added new ARM64 symbol: CONFIG_ARM64_ERRATUM_1024718 Compile-tested on: cns3xxx, imx6, mvebu (arm64), x86_64 Runtime-tested on: cns3xxx, imx6, x86_64 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/ath79/patches-4.14/0022-MIPS-ath79-drop-pci.c.patch')
-rw-r--r--target/linux/ath79/patches-4.14/0022-MIPS-ath79-drop-pci.c.patch20
1 files changed, 6 insertions, 14 deletions
diff --git a/target/linux/ath79/patches-4.14/0022-MIPS-ath79-drop-pci.c.patch b/target/linux/ath79/patches-4.14/0022-MIPS-ath79-drop-pci.c.patch
index 036bfc31c7..58ed122c68 100644
--- a/target/linux/ath79/patches-4.14/0022-MIPS-ath79-drop-pci.c.patch
+++ b/target/linux/ath79/patches-4.14/0022-MIPS-ath79-drop-pci.c.patch
@@ -16,10 +16,8 @@ Signed-off-by: John Crispin <john@phrozen.org>
delete mode 100644 arch/mips/ath79/pci.c
create mode 100644 arch/mips/pci/fixup-ath79.c
-Index: linux-4.14.25/arch/mips/ath79/Makefile
-===================================================================
---- linux-4.14.25.orig/arch/mips/ath79/Makefile
-+++ linux-4.14.25/arch/mips/ath79/Makefile
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
@@ -11,7 +11,6 @@
obj-y := prom.o setup.o irq.o common.o clock.o
@@ -28,9 +26,7 @@ Index: linux-4.14.25/arch/mips/ath79/Makefile
#
# Devices
-Index: linux-4.14.25/arch/mips/ath79/pci.c
-===================================================================
---- linux-4.14.25.orig/arch/mips/ath79/pci.c
+--- a/arch/mips/ath79/pci.c
+++ /dev/null
@@ -1,285 +0,0 @@
-/*
@@ -318,10 +314,8 @@ Index: linux-4.14.25/arch/mips/ath79/pci.c
-
- return pdev ? 0 : -ENODEV;
-}
-Index: linux-4.14.25/arch/mips/pci/Makefile
-===================================================================
---- linux-4.14.25.orig/arch/mips/pci/Makefile
-+++ linux-4.14.25/arch/mips/pci/Makefile
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
@@ -29,6 +29,7 @@ obj-$(CONFIG_MIPS_PCI_VIRTIO) += pci-vir
#
# These are still pretty much in the old state, watch, go blind.
@@ -330,10 +324,8 @@ Index: linux-4.14.25/arch/mips/pci/Makefile
obj-$(CONFIG_LASAT) += pci-lasat.o
obj-$(CONFIG_MIPS_COBALT) += fixup-cobalt.o
obj-$(CONFIG_LEMOTE_FULOONG2E) += fixup-fuloong2e.o ops-loongson2.o
-Index: linux-4.14.25/arch/mips/pci/fixup-ath79.c
-===================================================================
--- /dev/null
-+++ linux-4.14.25/arch/mips/pci/fixup-ath79.c
++++ b/arch/mips/pci/fixup-ath79.c
@@ -0,0 +1,21 @@
+/*
+ * Copyright (C) 2018 John Crispin <john@phrozen.org>