aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-4.14/0004-phy-add-ath79-usb-phys.patch
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2018-05-17 18:41:26 +0200
committerJohn Crispin <john@phrozen.org>2018-05-18 09:10:46 +0200
commite2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73 (patch)
tree01d46d7549a9554ff8a659993b97b3d07f5e59f1 /target/linux/ath79/patches-4.14/0004-phy-add-ath79-usb-phys.patch
parent12f44b83a8db2c95274839e2e41792e096021f29 (diff)
downloadupstream-e2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73.tar.gz
upstream-e2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73.tar.bz2
upstream-e2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73.zip
kernel: bump 4.14 to 4.14.41
Refreshed all patches Dropped upstreamed patches: 522-PCI-aardvark-fix-logic-in-PCI-configuration-read-write-functions.patch 523-PCI-aardvark-set-PIO_ADDR_LS-correctly-in-advk_pcie_rd_conf.patch 525-PCI-aardvark-use-isr1-instead-of-isr0-interrupt-in-legacy-irq-mode.patch 527-PCI-aardvark-fix-PCIe-max-read-request-size-setting.patch updated patches: 524-PCI-aardvark-set-host-and-device-to-the-same-MAX-payload-size.patch 030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch Added new ARM64 symbol: CONFIG_ARM64_ERRATUM_1024718 Compile-tested on: cns3xxx, imx6, mvebu (arm64), x86_64 Runtime-tested on: cns3xxx, imx6, x86_64 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/ath79/patches-4.14/0004-phy-add-ath79-usb-phys.patch')
-rw-r--r--target/linux/ath79/patches-4.14/0004-phy-add-ath79-usb-phys.patch20
1 files changed, 6 insertions, 14 deletions
diff --git a/target/linux/ath79/patches-4.14/0004-phy-add-ath79-usb-phys.patch b/target/linux/ath79/patches-4.14/0004-phy-add-ath79-usb-phys.patch
index 38763d2d74..6280baf913 100644
--- a/target/linux/ath79/patches-4.14/0004-phy-add-ath79-usb-phys.patch
+++ b/target/linux/ath79/patches-4.14/0004-phy-add-ath79-usb-phys.patch
@@ -13,10 +13,8 @@ Signed-off-by: John Crispin <john@phrozen.org>
create mode 100644 drivers/phy/phy-ar7100-usb.c
create mode 100644 drivers/phy/phy-ar7200-usb.c
-Index: linux-4.14.37/drivers/phy/Kconfig
-===================================================================
---- linux-4.14.37.orig/drivers/phy/Kconfig
-+++ linux-4.14.37/drivers/phy/Kconfig
+--- a/drivers/phy/Kconfig
++++ b/drivers/phy/Kconfig
@@ -15,6 +15,22 @@ config GENERIC_PHY
phy users can obtain reference to the PHY. All the users of this
framework should select this config.
@@ -40,10 +38,8 @@ Index: linux-4.14.37/drivers/phy/Kconfig
config PHY_LPC18XX_USB_OTG
tristate "NXP LPC18xx/43xx SoC USB OTG PHY driver"
depends on OF && (ARCH_LPC18XX || COMPILE_TEST)
-Index: linux-4.14.37/drivers/phy/Makefile
-===================================================================
---- linux-4.14.37.orig/drivers/phy/Makefile
-+++ linux-4.14.37/drivers/phy/Makefile
+--- a/drivers/phy/Makefile
++++ b/drivers/phy/Makefile
@@ -4,6 +4,8 @@
#
@@ -53,10 +49,8 @@ Index: linux-4.14.37/drivers/phy/Makefile
obj-$(CONFIG_PHY_LPC18XX_USB_OTG) += phy-lpc18xx-usb-otg.o
obj-$(CONFIG_PHY_XGENE) += phy-xgene.o
obj-$(CONFIG_PHY_PISTACHIO_USB) += phy-pistachio-usb.o
-Index: linux-4.14.37/drivers/phy/phy-ar7100-usb.c
-===================================================================
--- /dev/null
-+++ linux-4.14.37/drivers/phy/phy-ar7100-usb.c
++++ b/drivers/phy/phy-ar7100-usb.c
@@ -0,0 +1,140 @@
+/*
+ * Copyright (C) 2018 John Crispin <john@phrozen.org>
@@ -198,10 +192,8 @@ Index: linux-4.14.37/drivers/phy/phy-ar7100-usb.c
+MODULE_DESCRIPTION("ATH79 USB PHY driver");
+MODULE_AUTHOR("Alban Bedel <albeu@free.fr>");
+MODULE_LICENSE("GPL");
-Index: linux-4.14.37/drivers/phy/phy-ar7200-usb.c
-===================================================================
--- /dev/null
-+++ linux-4.14.37/drivers/phy/phy-ar7200-usb.c
++++ b/drivers/phy/phy-ar7200-usb.c
@@ -0,0 +1,123 @@
+/*
+ * Copyright (C) 2015 Alban Bedel <albeu@free.fr>