aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-4.14/0003-leds-add-reset-controller-based-driver.patch
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2018-05-17 18:41:26 +0200
committerJohn Crispin <john@phrozen.org>2018-05-18 09:10:46 +0200
commite2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73 (patch)
tree01d46d7549a9554ff8a659993b97b3d07f5e59f1 /target/linux/ath79/patches-4.14/0003-leds-add-reset-controller-based-driver.patch
parent12f44b83a8db2c95274839e2e41792e096021f29 (diff)
downloadupstream-e2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73.tar.gz
upstream-e2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73.tar.bz2
upstream-e2aa0c3f8b49f62fc83ec90f0bc5a67560fffa73.zip
kernel: bump 4.14 to 4.14.41
Refreshed all patches Dropped upstreamed patches: 522-PCI-aardvark-fix-logic-in-PCI-configuration-read-write-functions.patch 523-PCI-aardvark-set-PIO_ADDR_LS-correctly-in-advk_pcie_rd_conf.patch 525-PCI-aardvark-use-isr1-instead-of-isr0-interrupt-in-legacy-irq-mode.patch 527-PCI-aardvark-fix-PCIe-max-read-request-size-setting.patch updated patches: 524-PCI-aardvark-set-host-and-device-to-the-same-MAX-payload-size.patch 030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch Added new ARM64 symbol: CONFIG_ARM64_ERRATUM_1024718 Compile-tested on: cns3xxx, imx6, mvebu (arm64), x86_64 Runtime-tested on: cns3xxx, imx6, x86_64 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/ath79/patches-4.14/0003-leds-add-reset-controller-based-driver.patch')
-rw-r--r--target/linux/ath79/patches-4.14/0003-leds-add-reset-controller-based-driver.patch16
1 files changed, 5 insertions, 11 deletions
diff --git a/target/linux/ath79/patches-4.14/0003-leds-add-reset-controller-based-driver.patch b/target/linux/ath79/patches-4.14/0003-leds-add-reset-controller-based-driver.patch
index 358da3b830..495d79288b 100644
--- a/target/linux/ath79/patches-4.14/0003-leds-add-reset-controller-based-driver.patch
+++ b/target/linux/ath79/patches-4.14/0003-leds-add-reset-controller-based-driver.patch
@@ -11,10 +11,8 @@ Signed-off-by: John Crispin <john@phrozen.org>
3 files changed, 149 insertions(+)
create mode 100644 drivers/leds/leds-reset.c
-Index: linux-4.14.32/drivers/leds/Kconfig
-===================================================================
---- linux-4.14.32.orig/drivers/leds/Kconfig
-+++ linux-4.14.32/drivers/leds/Kconfig
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
@@ -696,6 +696,17 @@ config LEDS_NIC78BX
To compile this driver as a module, choose M here: the module
will be called leds-nic78bx.
@@ -33,10 +31,8 @@ Index: linux-4.14.32/drivers/leds/Kconfig
comment "LED Triggers"
source "drivers/leds/trigger/Kconfig"
-Index: linux-4.14.32/drivers/leds/leds-reset.c
-===================================================================
--- /dev/null
-+++ linux-4.14.32/drivers/leds/leds-reset.c
++++ b/drivers/leds/leds-reset.c
@@ -0,0 +1,137 @@
+/*
+ * Copyright (C) 2018 John Crispin <john@phrozen.org>
@@ -175,10 +171,8 @@ Index: linux-4.14.32/drivers/leds/leds-reset.c
+MODULE_DESCRIPTION("reset controller LED driver");
+MODULE_LICENSE("GPL");
+MODULE_ALIAS("platform:leds-reset");
-Index: linux-4.14.32/drivers/leds/Makefile
-===================================================================
---- linux-4.14.32.orig/drivers/leds/Makefile
-+++ linux-4.14.32/drivers/leds/Makefile
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
@@ -73,6 +73,7 @@ obj-$(CONFIG_LEDS_PM8058) += leds-pm805
obj-$(CONFIG_LEDS_MLXCPLD) += leds-mlxcpld.o
obj-$(CONFIG_LEDS_NIC78BX) += leds-nic78bx.o