aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/nand/target.mk
diff options
context:
space:
mode:
authorRoger Pueyo Centelles <roger.pueyo@guifi.net>2020-01-26 17:56:05 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2020-02-26 14:46:46 +0100
commit8f93c05a591bd68e4d8eaa0a8468ce2263762004 (patch)
treedffaf554ef38e457d0c893b6798639862a07de3d /target/linux/ath79/nand/target.mk
parentc81b2e94c7d89fbf9f03aa4680ebb3d26cede872 (diff)
downloadupstream-8f93c05a591bd68e4d8eaa0a8468ce2263762004.tar.gz
upstream-8f93c05a591bd68e4d8eaa0a8468ce2263762004.tar.bz2
upstream-8f93c05a591bd68e4d8eaa0a8468ce2263762004.zip
ath79: add support for MikroTik RouterBOARD 922UAGS-5HPacD
This patch ports support for the MikroTik RouterBOARD 922UAGS-5HPacD with a built-in 802.11ac High-Power radio (31dBm), which was already available in the ar71xx target. See https://mikrotik.com/product/RB922UAGS-5HPacD for more info. Specifications: - SoC: Qualcomm Atheros QCA9558 (720 MHz) - RAM: 128 MB - Storage: 128 MB NAND - Wireless: external QCA9882 802.11a/ac 2x2:2 - Ethernet: 1x 1000/100/10 Mbps, integrated, via AR8031 PHY, passive PoE-in 24V - SFP: 1x host - USB: 1x 2.0 type A - PCIe: 1x Mini slot (also contains USB 2.0 for 3G/LTE modems) - SIM slot: 1x mini-SIM Working: - Board/system detection - SPI and NAND storage - PCIe - USB type A host - Wireless - Ethernet - LEDs (user, phy0) - Reset button - Sysupgrade to/from ar71xx Not supported: - RSSI LEDs - SFP cage Installation methods: - Sysupgrade from ar71xx (it is advisable to use the -n option to wipe any previous settings), or - Boot the initramfs image via TFTP and then flash the sysupgrade image using "sysupgrade -n" Signed-off-by: Roger Pueyo Centelles <roger.pueyo@guifi.net>
Diffstat (limited to 'target/linux/ath79/nand/target.mk')
-rw-r--r--target/linux/ath79/nand/target.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ath79/nand/target.mk b/target/linux/ath79/nand/target.mk
index c565c9b2b8..fd5216b0eb 100644
--- a/target/linux/ath79/nand/target.mk
+++ b/target/linux/ath79/nand/target.mk
@@ -1,6 +1,6 @@
BOARDNAME := Generic devices with NAND flash
-FEATURES += squashfs nand
+FEATURES += squashfs nand minor
DEFAULT_PACKAGES += wpad-basic