aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/modules.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2018-05-06 10:20:11 +0200
committerJohn Crispin <john@phrozen.org>2018-05-07 08:06:51 +0200
commit53c474abbdfef8eb3499e2d10c9ad491788b8a72 (patch)
treeacd19415420664f59bc63c1ceb4ad37bb7323027 /target/linux/ath79/modules.mk
parent3dc523f232ff01d31d59345f5fa6de508d5059ef (diff)
downloadupstream-53c474abbdfef8eb3499e2d10c9ad491788b8a72.tar.gz
upstream-53c474abbdfef8eb3499e2d10c9ad491788b8a72.tar.bz2
upstream-53c474abbdfef8eb3499e2d10c9ad491788b8a72.zip
ath79: add new OF only target for QCA MIPS silicon
This target aims to replace ar71xx mid-term. The big part that is still missing is making the MMIO/AHB wifi work using OF. NAND and mikrotik subtargets will follow. Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ath79/modules.mk')
-rw-r--r--target/linux/ath79/modules.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ath79/modules.mk b/target/linux/ath79/modules.mk
new file mode 100644
index 0000000000..946440dd61
--- /dev/null
+++ b/target/linux/ath79/modules.mk
@@ -0,0 +1,16 @@
+LEDS_MENU:=LED modules
+
+define KernelPackage/leds-reset
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=reset controller LED support
+ DEPENDS:= @TARGET_ath79
+ KCONFIG:=CONFIG_LEDS_RESET=m
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-reset.ko
+ AUTOLOAD:=$(call AutoLoad,60,leds-reset,1)
+endef
+
+define KernelPackage/leds-reset/description
+ Kernel module for LEDs on reset lines
+endef
+
+$(eval $(call KernelPackage,leds-reset))