aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorMichał Kępień <openwrt@kempniu.pl>2023-06-17 19:12:21 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-07-12 20:45:43 +0200
commit98b397d4fb56a7049eeda00ff138f439db32dcef (patch)
treeac5a192d8a7051656ba9f4c775ad59df1c93ff82 /target/linux/ath79/image
parent7bb616d3006e5efc7474e552e861bfece453fa70 (diff)
downloadupstream-98b397d4fb56a7049eeda00ff138f439db32dcef.tar.gz
upstream-98b397d4fb56a7049eeda00ff138f439db32dcef.tar.bz2
upstream-98b397d4fb56a7049eeda00ff138f439db32dcef.zip
ath79: add support for MikroTik RB951G-2HnD
MikroTik RB951G-2HnD is a wireless SOHO router that was previously supported by the ar71xx target, see commit 7a709573d7 ("ar71xx: add kernel support for the Mikrotik RB951G board"). Specifications -------------- - SoC: Atheros AR9344 (600 MHz) - RAM: 128 MB (2x 64 MB) - Storage: 128 MB NAND flash (various manufacturers) - Ethernet: Atheros AR8327 switch, 5x 10/100/1000 Mbit/s - 1x PoE in (port 1, 8-30 V input) - Wireless: Atheros AR9340 (802.11b/g/n) - USB: 2.0 (1A) - 8x LED: - 1x power (green, not configurable) - 1x user (green, not configurable) - 5x GE ports (green, not configurable) - 1x wireless (green, not configurable) - 1x button (restart) Unlike on the RB951Ui-2HnD, none of the LEDs on this device seem to be GPIO-controllable, which was also the case for older OpenWRT versions that supported this board via a mach file. The Ethernet port LEDs are controlled by the switch chip. See https://mikrotik.com/product/RB951G-2HnD for more details. Flashing -------- TFTP boot initramfs image and then perform sysupgrade. Follow common MikroTik procedures at https://openwrt.org/toh/mikrotik/common. Signed-off-by: Michał Kępień <openwrt@kempniu.pl> (cherry picked from commit db02cecd6ad2e5962e6e9d8307da34855a083ad6)
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/mikrotik.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/mikrotik.mk b/target/linux/ath79/image/mikrotik.mk
index 3f65b35c8c..683e9a3330 100644
--- a/target/linux/ath79/image/mikrotik.mk
+++ b/target/linux/ath79/image/mikrotik.mk
@@ -48,6 +48,15 @@ define Device/mikrotik_routerboard-922uags-5hpacd
endef
TARGET_DEVICES += mikrotik_routerboard-922uags-5hpacd
+define Device/mikrotik_routerboard-951g-2hnd
+ $(Device/mikrotik_nand)
+ SOC := ar9344
+ DEVICE_MODEL := RouterBOARD 951G-2HnD
+ DEVICE_PACKAGES += kmod-usb-ohci kmod-usb2
+ SUPPORTED_DEVICES += rb-951g-2hnd
+endef
+TARGET_DEVICES += mikrotik_routerboard-951g-2hnd
+
define Device/mikrotik_routerboard-951ui-2hnd
$(Device/mikrotik_nand)
SOC := ar9344