aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2021-12-25 09:19:52 +0100
committerPaul Spooren <mail@aparcar.org>2022-06-11 21:22:58 +0200
commitf4415f7635164ec07ddc22f56df93555804b5767 (patch)
tree3777a8736e7f5ae0765fc1d83dce61e462220bfc /target/linux/ath79/image
parent31d86a1a119265393db02aa66e6bc6518ee7b905 (diff)
downloadupstream-f4415f7635164ec07ddc22f56df93555804b5767.tar.gz
upstream-f4415f7635164ec07ddc22f56df93555804b5767.tar.bz2
upstream-f4415f7635164ec07ddc22f56df93555804b5767.zip
ath79: move ubnt-xm to tiny
ath79 has was bumped to 5.10. With this, as with every kernel change, the kernel has become larger. However, although the kernel gets bigger, there are still enough flash resources. But the RAM reaches its capacity limits. The tiny image comes with fewer kernel flags enabled and fewer daemons. Improves: 15aa53d7ee65 ("ath79: switch to Kernel 5.10") Tested-by: Robert Foss <me@robertfoss.se> Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/Makefile1
-rw-r--r--target/linux/ath79/image/common-ubnt.mk142
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk225
-rw-r--r--target/linux/ath79/image/generic.mk1
-rw-r--r--target/linux/ath79/image/tiny-ubnt.mk83
5 files changed, 228 insertions, 224 deletions
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index 768ec57044..2a7a0abd50 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -105,6 +105,7 @@ endif
ifeq ($(SUBTARGET),tiny)
include tiny-netgear.mk
include tiny-tp-link.mk
+include tiny-ubnt.mk
endif
$(eval $(call BuildImage))
diff --git a/target/linux/ath79/image/common-ubnt.mk b/target/linux/ath79/image/common-ubnt.mk
new file mode 100644
index 0000000000..625f0b4f3f
--- /dev/null
+++ b/target/linux/ath79/image/common-ubnt.mk
@@ -0,0 +1,142 @@
+DEVICE_VARS += UBNT_BOARD UBNT_CHIP UBNT_TYPE UBNT_VERSION UBNT_REVISION
+
+# On M (XW) devices the U-Boot as of version 1.1.4-s1039 doesn't like
+# VERSION_DIST being on the place of major(?) version number, so we need to
+# use some number.
+UBNT_REVISION := $(VERSION_DIST)-$(REVISION)
+
+# mkubntimage is using the kernel image direct
+# routerboard creates partitions out of the ubnt header
+define Build/mkubntimage
+ -$(STAGING_DIR_HOST)/bin/mkfwimage -B $(UBNT_BOARD) \
+ -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-$(VERSION_DIST)-$(REVISION) \
+ -k $(IMAGE_KERNEL) -r $@ -o $@
+endef
+
+define Build/mkubntimage2
+ -$(STAGING_DIR_HOST)/bin/mkfwimage2 -f 0x9f000000 \
+ -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-$(VERSION_DIST)-$(REVISION) \
+ -p jffs2:0x50000:0xf60000:0:0:$@ \
+ -o $@.new
+ @mv $@.new $@
+endef
+
+# all UBNT XM/WA devices expect the kernel image to have 1024k while flash, when
+# booting the image, the size doesn't matter.
+define Build/mkubntimage-split
+ -[ -f $@ ] && ( \
+ dd if=$@ of=$@.old1 bs=1024k count=1; \
+ dd if=$@ of=$@.old2 bs=1024k skip=1; \
+ $(STAGING_DIR_HOST)/bin/mkfwimage -B $(UBNT_BOARD) \
+ -v $(UBNT_TYPE).$(UBNT_CHIP).v$(UBNT_VERSION)-$(UBNT_REVISION) \
+ -k $@.old1 -r $@.old2 -o $@; \
+ rm $@.old1 $@.old2 )
+endef
+
+# UBNT_BOARD e.g. one of (XS2, XS5, RS, XM)
+# UBNT_TYPE e.g. one of (BZ, XM, XW)
+# UBNT_CHIP e.g. one of (ar7240, ar933x, ar934x)
+# UBNT_VERSION e.g. one of (6.0.0, 8.5.3)
+define Device/ubnt
+ DEVICE_VENDOR := Ubiquiti
+ DEVICE_PACKAGES := kmod-usb2
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | check-size | mkubntimage-split
+endef
+
+define Device/ubnt-bz
+ $(Device/ubnt)
+ SOC := ar7241
+ IMAGE_SIZE := 7448k
+ UBNT_BOARD := XM
+ UBNT_CHIP := ar7240
+ UBNT_TYPE := BZ
+ UBNT_VERSION := 6.0.0
+endef
+
+define Device/ubnt-sw
+ $(Device/ubnt)
+ SOC := ar7242
+ DEVICE_PACKAGES += kmod-usb-ohci
+ IMAGE_SIZE := 7552k
+ UBNT_BOARD := SW
+ UBNT_CHIP := ar7240
+ UBNT_TYPE := SW
+ UBNT_VERSION := 1.4.1
+ KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma | uImage lzma
+endef
+
+define Device/ubnt-2wa
+ $(Device/ubnt)
+ SOC := ar9342
+ IMAGE_SIZE := 15744k
+ UBNT_BOARD := WA
+ UBNT_CHIP := ar934x
+ UBNT_TYPE := 2WA
+ UBNT_VERSION := 8.5.3
+endef
+
+define Device/ubnt-wa
+ $(Device/ubnt)
+ SOC := ar9342
+ IMAGE_SIZE := 15744k
+ UBNT_BOARD := WA
+ UBNT_CHIP := ar934x
+ UBNT_TYPE := WA
+ UBNT_VERSION := 8.5.3
+endef
+
+define Device/ubnt-xc
+ $(Device/ubnt)
+ IMAGE_SIZE := 15744k
+ UBNT_BOARD := XC
+ UBNT_CHIP := qca955x
+ UBNT_TYPE := XC
+ UBNT_VERSION := 8.5.3
+endef
+
+define Device/ubnt-xm
+ $(Device/ubnt)
+ DEVICE_VARIANT := XM
+ DEVICE_PACKAGES += kmod-usb-ohci
+ IMAGE_SIZE := 7448k
+ UBNT_BOARD := XM
+ UBNT_CHIP := ar7240
+ UBNT_REVISION := 42.$(UBNT_REVISION)
+ UBNT_TYPE := XM
+ UBNT_VERSION := 6.0.0
+ KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma | uImage lzma
+endef
+
+define Device/ubnt-xw
+ $(Device/ubnt)
+ SOC := ar9342
+ DEVICE_VARIANT := XW
+ IMAGE_SIZE := 7552k
+ UBNT_BOARD := XM
+ UBNT_CHIP := ar934x
+ UBNT_REVISION := 42.$(UBNT_REVISION)
+ UBNT_TYPE := XW
+ UBNT_VERSION := 6.0.4
+endef
+
+define Device/ubnt-unifi-jffs2
+ $(Device/ubnt)
+ KERNEL_SIZE := 3072k
+ IMAGE_SIZE := 15744k
+ UBNT_TYPE := BZ
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | jffs2 kernel0
+ IMAGES := sysupgrade.bin factory.bin
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs |\
+ pad-rootfs | check-size | append-metadata
+ IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage2
+endef
+
+define Device/ubnt-acb
+ $(Device/ubnt)
+ IMAGE_SIZE := 15744k
+ UBNT_BOARD := ACB
+ UBNT_TYPE := ACB
+ UBNT_VERSION := 2.5.0
+endef
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 2381d92567..5259a339df 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -1,145 +1,4 @@
-DEVICE_VARS += UBNT_BOARD UBNT_CHIP UBNT_TYPE UBNT_VERSION UBNT_REVISION
-
-# On M (XW) devices the U-Boot as of version 1.1.4-s1039 doesn't like
-# VERSION_DIST being on the place of major(?) version number, so we need to
-# use some number.
-UBNT_REVISION := $(VERSION_DIST)-$(REVISION)
-
-# mkubntimage is using the kernel image direct
-# routerboard creates partitions out of the ubnt header
-define Build/mkubntimage
- -$(STAGING_DIR_HOST)/bin/mkfwimage -B $(UBNT_BOARD) \
- -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-$(VERSION_DIST)-$(REVISION) \
- -k $(IMAGE_KERNEL) -r $@ -o $@
-endef
-
-define Build/mkubntimage2
- -$(STAGING_DIR_HOST)/bin/mkfwimage2 -f 0x9f000000 \
- -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-$(VERSION_DIST)-$(REVISION) \
- -p jffs2:0x50000:0xf60000:0:0:$@ \
- -o $@.new
- @mv $@.new $@
-endef
-
-# all UBNT XM/WA devices expect the kernel image to have 1024k while flash, when
-# booting the image, the size doesn't matter.
-define Build/mkubntimage-split
- -[ -f $@ ] && ( \
- dd if=$@ of=$@.old1 bs=1024k count=1; \
- dd if=$@ of=$@.old2 bs=1024k skip=1; \
- $(STAGING_DIR_HOST)/bin/mkfwimage -B $(UBNT_BOARD) \
- -v $(UBNT_TYPE).$(UBNT_CHIP).v$(UBNT_VERSION)-$(UBNT_REVISION) \
- -k $@.old1 -r $@.old2 -o $@; \
- rm $@.old1 $@.old2 )
-endef
-
-# UBNT_BOARD e.g. one of (XS2, XS5, RS, XM)
-# UBNT_TYPE e.g. one of (BZ, XM, XW)
-# UBNT_CHIP e.g. one of (ar7240, ar933x, ar934x)
-# UBNT_VERSION e.g. one of (6.0.0, 8.5.3)
-define Device/ubnt
- DEVICE_VENDOR := Ubiquiti
- DEVICE_PACKAGES := kmod-usb2
- IMAGES += factory.bin
- IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
- append-rootfs | pad-rootfs | check-size | mkubntimage-split
-endef
-
-define Device/ubnt-bz
- $(Device/ubnt)
- SOC := ar7241
- IMAGE_SIZE := 7448k
- UBNT_BOARD := XM
- UBNT_CHIP := ar7240
- UBNT_TYPE := BZ
- UBNT_VERSION := 6.0.0
-endef
-
-define Device/ubnt-sw
- $(Device/ubnt)
- SOC := ar7242
- DEVICE_PACKAGES += kmod-usb-ohci
- IMAGE_SIZE := 7552k
- UBNT_BOARD := SW
- UBNT_CHIP := ar7240
- UBNT_TYPE := SW
- UBNT_VERSION := 1.4.1
- KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma | uImage lzma
-endef
-
-define Device/ubnt-2wa
- $(Device/ubnt)
- SOC := ar9342
- IMAGE_SIZE := 15744k
- UBNT_BOARD := WA
- UBNT_CHIP := ar934x
- UBNT_TYPE := 2WA
- UBNT_VERSION := 8.5.3
-endef
-
-define Device/ubnt-wa
- $(Device/ubnt)
- SOC := ar9342
- IMAGE_SIZE := 15744k
- UBNT_BOARD := WA
- UBNT_CHIP := ar934x
- UBNT_TYPE := WA
- UBNT_VERSION := 8.5.3
-endef
-
-define Device/ubnt-xc
- $(Device/ubnt)
- IMAGE_SIZE := 15744k
- UBNT_BOARD := XC
- UBNT_CHIP := qca955x
- UBNT_TYPE := XC
- UBNT_VERSION := 8.5.3
-endef
-
-define Device/ubnt-xm
- $(Device/ubnt)
- DEVICE_VARIANT := XM
- DEVICE_PACKAGES += kmod-usb-ohci
- IMAGE_SIZE := 7448k
- UBNT_BOARD := XM
- UBNT_CHIP := ar7240
- UBNT_REVISION := 42.$(UBNT_REVISION)
- UBNT_TYPE := XM
- UBNT_VERSION := 6.0.0
- KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma | uImage lzma
-endef
-
-define Device/ubnt-xw
- $(Device/ubnt)
- SOC := ar9342
- DEVICE_VARIANT := XW
- IMAGE_SIZE := 7552k
- UBNT_BOARD := XM
- UBNT_CHIP := ar934x
- UBNT_REVISION := 42.$(UBNT_REVISION)
- UBNT_TYPE := XW
- UBNT_VERSION := 6.0.4
-endef
-
-define Device/ubnt-unifi-jffs2
- $(Device/ubnt)
- KERNEL_SIZE := 3072k
- IMAGE_SIZE := 15744k
- UBNT_TYPE := BZ
- KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | jffs2 kernel0
- IMAGES := sysupgrade.bin factory.bin
- IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs |\
- pad-rootfs | check-size | append-metadata
- IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage2
-endef
-
-define Device/ubnt-acb
- $(Device/ubnt)
- IMAGE_SIZE := 15744k
- UBNT_BOARD := ACB
- UBNT_TYPE := ACB
- UBNT_VERSION := 2.5.0
-endef
+include ./common-ubnt.mk
define Device/ubnt_aircube-ac
$(Device/ubnt-acb)
@@ -159,14 +18,6 @@ define Device/ubnt_aircube-isp
endef
TARGET_DEVICES += ubnt_aircube-isp
-define Device/ubnt_airrouter
- $(Device/ubnt-xm)
- SOC := ar7241
- DEVICE_MODEL := AirRouter
- SUPPORTED_DEVICES += airrouter
-endef
-TARGET_DEVICES += ubnt_airrouter
-
define Device/ubnt_bullet-ac
$(Device/ubnt-2wa)
DEVICE_MODEL := Bullet AC
@@ -174,26 +25,6 @@ define Device/ubnt_bullet-ac
endef
TARGET_DEVICES += ubnt_bullet-ac
-define Device/ubnt_bullet-m-ar7240
- $(Device/ubnt-xm)
- SOC := ar7240
- DEVICE_MODEL := Bullet M
- DEVICE_VARIANT := XM (AR7240)
- DEVICE_PACKAGES += rssileds
- SUPPORTED_DEVICES += bullet-m
-endef
-TARGET_DEVICES += ubnt_bullet-m-ar7240
-
-define Device/ubnt_bullet-m-ar7241
- $(Device/ubnt-xm)
- SOC := ar7241
- DEVICE_MODEL := Bullet M
- DEVICE_VARIANT := XM (AR7241)
- DEVICE_PACKAGES += rssileds
- SUPPORTED_DEVICES += bullet-m ubnt,bullet-m
-endef
-TARGET_DEVICES += ubnt_bullet-m-ar7241
-
define Device/ubnt_bullet-m-xw
$(Device/ubnt-xw)
DEVICE_MODEL := Bullet M
@@ -263,15 +94,6 @@ define Device/ubnt_nanobeam-m5-xw
endef
TARGET_DEVICES += ubnt_nanobeam-m5-xw
-define Device/ubnt_nanobridge-m
- $(Device/ubnt-xm)
- SOC := ar7241
- DEVICE_MODEL := NanoBridge M
- DEVICE_PACKAGES += rssileds
- SUPPORTED_DEVICES += bullet-m
-endef
-TARGET_DEVICES += ubnt_nanobridge-m
-
define Device/ubnt_nanostation-ac
$(Device/ubnt-wa)
DEVICE_MODEL := Nanostation AC
@@ -286,15 +108,6 @@ define Device/ubnt_nanostation-ac-loco
endef
TARGET_DEVICES += ubnt_nanostation-ac-loco
-define Device/ubnt_nanostation-loco-m
- $(Device/ubnt-xm)
- SOC := ar7241
- DEVICE_MODEL := Nanostation Loco M
- DEVICE_PACKAGES += rssileds
- SUPPORTED_DEVICES += bullet-m
-endef
-TARGET_DEVICES += ubnt_nanostation-loco-m
-
define Device/ubnt_nanostation-loco-m-xw
$(Device/ubnt-xw)
DEVICE_MODEL := Nanostation Loco M
@@ -303,15 +116,6 @@ define Device/ubnt_nanostation-loco-m-xw
endef
TARGET_DEVICES += ubnt_nanostation-loco-m-xw
-define Device/ubnt_nanostation-m
- $(Device/ubnt-xm)
- SOC := ar7241
- DEVICE_MODEL := Nanostation M
- DEVICE_PACKAGES += rssileds
- SUPPORTED_DEVICES += nanostation-m
-endef
-TARGET_DEVICES += ubnt_nanostation-m
-
define Device/ubnt_nanostation-m-xw
$(Device/ubnt-xw)
DEVICE_MODEL := Nanostation M
@@ -320,15 +124,6 @@ define Device/ubnt_nanostation-m-xw
endef
TARGET_DEVICES += ubnt_nanostation-m-xw
-define Device/ubnt_picostation-m
- $(Device/ubnt-xm)
- SOC := ar7241
- DEVICE_MODEL := Picostation M
- DEVICE_PACKAGES += rssileds
- SUPPORTED_DEVICES += bullet-m
-endef
-TARGET_DEVICES += ubnt_picostation-m
-
define Device/ubnt_powerbeam-5ac-500
$(Device/ubnt-xc)
SOC := qca9558
@@ -362,15 +157,6 @@ define Device/ubnt_powerbeam-m5-xw
endef
TARGET_DEVICES += ubnt_powerbeam-m5-xw
-define Device/ubnt_powerbridge-m
- $(Device/ubnt-xm)
- SOC := ar7241
- DEVICE_MODEL := PowerBridge M
- DEVICE_PACKAGES += rssileds
- SUPPORTED_DEVICES += bullet-m
-endef
-TARGET_DEVICES += ubnt_powerbridge-m
-
define Device/ubnt_rocket-5ac-lite
$(Device/ubnt-xc)
SOC := qca9558
@@ -380,15 +166,6 @@ define Device/ubnt_rocket-5ac-lite
endef
TARGET_DEVICES += ubnt_rocket-5ac-lite
-define Device/ubnt_rocket-m
- $(Device/ubnt-xm)
- SOC := ar7241
- DEVICE_MODEL := Rocket M
- DEVICE_PACKAGES += rssileds
- SUPPORTED_DEVICES += rocket-m
-endef
-TARGET_DEVICES += ubnt_rocket-m
-
define Device/ubnt_routerstation_common
DEVICE_PACKAGES := -kmod-ath9k -wpad-basic-wolfssl -uboot-envtools kmod-usb-ohci \
kmod-usb2 fconfig
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 9729eb7555..a6a6e5e499 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -3,6 +3,7 @@ include ./common-netgear.mk
include ./common-senao.mk
include ./common-tp-link.mk
include ./common-yuncore.mk
+include ./common-ubnt.mk
DEVICE_VARS += ADDPATTERN_ID ADDPATTERN_VERSION
DEVICE_VARS += SEAMA_SIGNATURE SEAMA_MTDBLOCK
diff --git a/target/linux/ath79/image/tiny-ubnt.mk b/target/linux/ath79/image/tiny-ubnt.mk
new file mode 100644
index 0000000000..805d193d45
--- /dev/null
+++ b/target/linux/ath79/image/tiny-ubnt.mk
@@ -0,0 +1,83 @@
+include ./common-ubnt.mk
+
+define Device/ubnt_airrouter
+ $(Device/ubnt-xm)
+ SOC := ar7241
+ DEVICE_MODEL := AirRouter
+ SUPPORTED_DEVICES += airrouter
+endef
+TARGET_DEVICES += ubnt_airrouter
+
+define Device/ubnt_nanobridge-m
+ $(Device/ubnt-xm)
+ SOC := ar7241
+ DEVICE_MODEL := NanoBridge M
+ DEVICE_PACKAGES += rssileds
+ SUPPORTED_DEVICES += bullet-m
+endef
+TARGET_DEVICES += ubnt_nanobridge-m
+
+define Device/ubnt_bullet-m-ar7240
+ $(Device/ubnt-xm)
+ SOC := ar7240
+ DEVICE_MODEL := Bullet M
+ DEVICE_VARIANT := XM (AR7240)
+ DEVICE_PACKAGES += rssileds
+ SUPPORTED_DEVICES += bullet-m
+endef
+TARGET_DEVICES += ubnt_bullet-m-ar7240
+
+define Device/ubnt_bullet-m-ar7241
+ $(Device/ubnt-xm)
+ SOC := ar7241
+ DEVICE_MODEL := Bullet M
+ DEVICE_VARIANT := XM (AR7241)
+ DEVICE_PACKAGES += rssileds
+ SUPPORTED_DEVICES += bullet-m ubnt,bullet-m
+endef
+TARGET_DEVICES += ubnt_bullet-m-ar7241
+
+define Device/ubnt_picostation-m
+ $(Device/ubnt-xm)
+ SOC := ar7241
+ DEVICE_MODEL := Picostation M
+ DEVICE_PACKAGES += rssileds
+ SUPPORTED_DEVICES += bullet-m
+endef
+TARGET_DEVICES += ubnt_picostation-m
+
+define Device/ubnt_nanostation-m
+ $(Device/ubnt-xm)
+ SOC := ar7241
+ DEVICE_MODEL := Nanostation M
+ DEVICE_PACKAGES += rssileds
+ SUPPORTED_DEVICES += nanostation-m
+endef
+TARGET_DEVICES += ubnt_nanostation-m
+
+define Device/ubnt_nanostation-loco-m
+ $(Device/ubnt-xm)
+ SOC := ar7241
+ DEVICE_MODEL := Nanostation Loco M
+ DEVICE_PACKAGES += rssileds
+ SUPPORTED_DEVICES += bullet-m
+endef
+TARGET_DEVICES += ubnt_nanostation-loco-m
+
+define Device/ubnt_powerbridge-m
+ $(Device/ubnt-xm)
+ SOC := ar7241
+ DEVICE_MODEL := PowerBridge M
+ DEVICE_PACKAGES += rssileds
+ SUPPORTED_DEVICES += bullet-m
+endef
+TARGET_DEVICES += ubnt_powerbridge-m
+
+define Device/ubnt_rocket-m
+ $(Device/ubnt-xm)
+ SOC := ar7241
+ DEVICE_MODEL := Rocket M
+ DEVICE_PACKAGES += rssileds
+ SUPPORTED_DEVICES += rocket-m
+endef
+TARGET_DEVICES += ubnt_rocket-m