aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorRomain Mahoux <romain@mahoux.fr>2021-06-08 11:52:18 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-08-25 01:42:17 +0200
commite2d08084c30e1f25559bfc1c745c0d0854a75636 (patch)
tree54366a29132041b23338d51738edd1cf1c097658 /target/linux/ath79/image
parent269758a5bcea1376d037dfea62f161ff8562e489 (diff)
downloadupstream-e2d08084c30e1f25559bfc1c745c0d0854a75636.tar.gz
upstream-e2d08084c30e1f25559bfc1c745c0d0854a75636.tar.bz2
upstream-e2d08084c30e1f25559bfc1c745c0d0854a75636.zip
ath79: add support for Compex WPJ558 (16M)
Specifications: - SoC: QCA9558 - DRAM: 128MB DDR2 - Flash: 16MB SPI-NOR - Wireless: on-board abgn 2×2 2.4GHz radio - Ethernet: 2x 10/100/1000 Mbps (1x 802.11af PoE) - miniPCIe slot Flash instruction: - From u-boot tftpboot 0x80500000 openwrt-ath79-generic-compex_wpj558-16m-squashfs-sysupgrade.bin erase 0x9f030000 +$filesize cp.b $fileaddr 0x9f030000 $filesize boot - From cpximg loader The cpximg loader can be started either by holding the reset button during power up. Once it's running, a TFTP-server under 192.168.1.1 will accept the image appropriate for the board revision that is etched on the board. For example, if the board is labelled '6A07': tftp -v -m binary 192.168.1.1 -c put openwrt-ath79-generic-compex_wpj558-16m-squashfs-cpximg-6a07.bin Signed-off-by: Romain Mahoux <romain@mahoux.fr> [convert to nvmem, remove redundant lan_mac in 02_network] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 4b943ba282..5bcd4779d3 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -682,6 +682,20 @@ define Device/compex_wpj531-16m
endef
TARGET_DEVICES += compex_wpj531-16m
+define Device/compex_wpj558-16m
+ SOC := qca9558
+ IMAGE_SIZE := 16128k
+ DEVICE_VENDOR := Compex
+ DEVICE_MODEL := WPJ558
+ DEVICE_VARIANT := 16M
+ SUPPORTED_DEVICES += wpj558
+ IMAGES += cpximg-6a07.bin
+ IMAGE/cpximg-6a07.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | mkmylofw_16m 0x691 3
+ DEVICE_PACKAGES := kmod-gpio-beeper
+endef
+TARGET_DEVICES += compex_wpj558-16m
+
define Device/compex_wpj563
SOC := qca9563
DEVICE_PACKAGES := kmod-usb2 kmod-usb3