aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorThibaut VARÈNE <hacks@slashdirt.org>2022-06-12 21:48:40 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2022-06-30 10:05:25 +0200
commitd6a06e1d1801449f4e83f47ace2c0866206f564c (patch)
tree7754237b683f3aec3b51061c2de527f81b9998b3 /target/linux/ath79/image
parent344ecf433abc7754e5653cabfb92d696afbeebd2 (diff)
downloadupstream-d6a06e1d1801449f4e83f47ace2c0866206f564c.tar.gz
upstream-d6a06e1d1801449f4e83f47ace2c0866206f564c.tar.bz2
upstream-d6a06e1d1801449f4e83f47ace2c0866206f564c.zip
ath79: add support for RouterBOARD mAP
The MikroTik mAP-2nd (sold as mAP) is an indoor 2.4Ghz AP with 802.3af/at PoE input and passive PoE passthrough. See https://mikrotik.com/product/RBmAP2nD for more details. Specifications: - SoC: QCA9533 - RAM: 64MB - Storage: 16MB NOR - Wireless: QCA9533 802.11b/g/n 2x2 - Ethernet: 2x 10/100 ports, 802.3af/at PoE in port 1, 500 mA passive PoE out on port 2 - 7 user-controllable LEDs Note: the device is a tiny AP and does not distinguish between both ethernet ports roles, so they are both assigned to lan. With the current setup, ETH1 is connected to eth1 and ETH2 is connected to eth0 via the embedded switch port 2. Flashing: TFTP boot initramfs image and then perform sysupgrade. The "ETH1" port must be used to upload the TFTP image. Follow common MikroTik procedure as in https://openwrt.org/toh/mikrotik/common. Tested-By: Andrew Powers-Holmes <aholmes@omnom.net> Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org> (cherry picked from commit e1223dbee332b89caf71850eb909104529595c31)
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/mikrotik.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/mikrotik.mk b/target/linux/ath79/image/mikrotik.mk
index d8ae726e87..c90579fbb5 100644
--- a/target/linux/ath79/image/mikrotik.mk
+++ b/target/linux/ath79/image/mikrotik.mk
@@ -85,6 +85,15 @@ define Device/mikrotik_routerboard-lhg-5nd
endef
TARGET_DEVICES += mikrotik_routerboard-lhg-5nd
+define Device/mikrotik_routerboard-map-2nd
+ $(Device/mikrotik_nor)
+ SOC := qca9533
+ DEVICE_MODEL := RouterBOARD mAP-2nD (mAP)
+ DEVICE_PACKAGES += kmod-usb2 kmod-ledtrig-gpio
+ IMAGE_SIZE := 16256k
+endef
+TARGET_DEVICES += mikrotik_routerboard-map-2nd
+
define Device/mikrotik_routerboard-mapl-2nd
$(Device/mikrotik_nor)
SOC := qca9533