aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorWenli Looi <wlooi@ucalgary.ca>2021-06-12 16:32:33 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2022-02-07 00:03:27 +0100
commitc32008a37b81d0ab1062993241a1e9f0a8e73102 (patch)
treebde00c3a371be4fb24cd10a19202cfc3f4d64a05 /target/linux/ath79/image
parent6ede645282f94c32a33a2c6858375b8c2f609922 (diff)
downloadupstream-c32008a37b81d0ab1062993241a1e9f0a8e73102.tar.gz
upstream-c32008a37b81d0ab1062993241a1e9f0a8e73102.tar.bz2
upstream-c32008a37b81d0ab1062993241a1e9f0a8e73102.zip
ath79: add partial support for Netgear EX7300v2
Hardware -------- SoC: QCN5502 Flash: 16 MiB RAM: 128 MiB Ethernet: 1 gigabit port Wireless No1: QCN5502 on-chip 2.4GHz 4x4 Wireless No2: QCA9984 pcie 5GHz 4x4 USB: none Installation ------------ Flash the factory image using the stock web interface or TFTP the factory image to the bootloader. What works ---------- - LEDs - Ethernet port - 5GHz wifi (QCA9984 pcie) What doesn't work ----------------- - 2.4GHz wifi (QCN5502 on-chip) (I was not able to make this work, probably because ath9k requires some changes to support QCN5502.) Signed-off-by: Wenli Looi <wlooi@ucalgary.ca>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index b3598a2000..3b23267b70 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1580,6 +1580,23 @@ define Device/netgear_ex7300
endef
TARGET_DEVICES += netgear_ex7300
+define Device/netgear_ex7300-v2
+ $(Device/netgear_generic)
+ SOC := qcn5502
+ DEVICE_MODEL := EX7300
+ DEVICE_VARIANT := v2
+ UIMAGE_MAGIC := 0x27051956
+ NETGEAR_BOARD_ID := EX7300v2series
+ NETGEAR_HW_ID := 29765907+16+0+128
+ IMAGE_SIZE := 14528k
+ IMAGE/default := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | \
+ netgear-rootfs | pad-rootfs
+ IMAGE/sysupgrade.bin := $$(IMAGE/default) | check-size | append-metadata
+ IMAGE/factory.img := $$(IMAGE/default) | check-size | netgear-dni
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9984-ct
+endef
+TARGET_DEVICES += netgear_ex7300-v2
+
define Device/netgear_wndr3x00
$(Device/netgear_generic)
SOC := ar7161