aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorTamas Balogh <tamasbalogh@hotmail.com>2021-12-27 18:04:51 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-01-09 20:32:41 +0100
commitb29f4cf34cc8c83034b696d185325a655a23bc06 (patch)
treeeb8ef353c829ab1ef7dd41ca11944bed330bae1c /target/linux/ath79/image
parent0f50d3daff19a1eae513630a70f0c66af16db796 (diff)
downloadupstream-b29f4cf34cc8c83034b696d185325a655a23bc06.tar.gz
upstream-b29f4cf34cc8c83034b696d185325a655a23bc06.tar.bz2
upstream-b29f4cf34cc8c83034b696d185325a655a23bc06.zip
ath79: add support for ASUS RP-AC66
Asus RP-AC66 Repeater Hardware specifications: Board: AP152 SoC: QCA9563 DRAM: 64MB DDR2 Flash: 25l128 16MB SPI-NOR LAN/WAN: 1x1000M QCA8033 WiFi 5GHz: QCA9880 Clocks: CPU:775.000MHz, DDR:650.000MHz, AHB:258.333MHz, Ref:25.000MHz MAC addresses as verified by OEM firmware: use address source Lan/Wan *:24 art 0x1002 (label) 2G *:24 art 0x1002 5G *:26 art 0x5006 Installation: Asus windows recovery tool: - install the Asus firmware restoration utility - unplug the router, hold the reset button while powering it on - release when the power LED flashes slowly - specify a static IP on your computer: IP address: 192.168.1.75 Subnet mask 255.255.255.0 - Start the Asus firmware restoration utility, specify the factory image and press upload - Do not power off the device after OpenWrt has booted until the LED flashing. TFTP Recovery method: - set computer to a static ip, 192.168.1.75 - connect computer to the LAN 1 port of the router - hold the reset button while powering on the router for a few seconds - send firmware image using a tftp client; i.e from linux: $ tftp tftp> binary tftp> connect 192.168.1.1 tftp> put factory.bin tftp> quit Signed-off-by: Tamas Balogh <tamasbalogh@hotmail.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index ff24764740..5e211a33a4 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -330,6 +330,18 @@ define Device/aruba_ap-105
endef
TARGET_DEVICES += aruba_ap-105
+define Device/asus_rp-ac66
+ SOC := qca9563
+ DEVICE_VENDOR := ASUS
+ DEVICE_MODEL := RP-AC66
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs
+ DEVICE_PACKAGES := kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct \
+ rssileds -swconfig
+endef
+TARGET_DEVICES += asus_rp-ac66
+
define Device/atheros_db120
$(Device/loader-okli-uimage)
SOC := ar9344