aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorThibaut VARÈNE <hacks@slashdirt.org>2022-04-14 12:39:03 +0200
committerPetr Štetiar <ynezz@true.cz>2022-04-15 08:14:50 +0200
commit708b883168e624ede9f5897a55e5e722c6881d76 (patch)
treeaa0143297e317e82ebc1dbe32cfd047b90a10e69 /target/linux/ath79/image
parent65144c96eb7b987c1648b99fd3699ac5e948b52e (diff)
downloadupstream-708b883168e624ede9f5897a55e5e722c6881d76.tar.gz
upstream-708b883168e624ede9f5897a55e5e722c6881d76.tar.bz2
upstream-708b883168e624ede9f5897a55e5e722c6881d76.zip
ath79: add support for Yuncore XD3200
Specification: - QCA9563 (775MHz), 128MB RAM, 16MB SPI NOR - 2T2R 802.11b/g/n 2.4GHz - 2T2R 802.11n/ac 5GHz - 2x 10/100/1000 Mbps Ethernet, with 802.3at PoE support (WAN port) LED for 5 GHz WLAN is currently not supported as it is connected directly to the QCA9882 radio chip. Flash instructions: If your device comes with generic QSDK based firmware, you can login over telnet (login: root, empty password, default IP: 192.168.188.253), issue first (important!) 'fw_setenv' command and then perform regular upgrade, using 'sysupgrade -n -F ...' (you can use 'wget' to download image to the device, SSH server is not available): fw_setenv bootcmd "bootm 0x9f050000 || bootm 0x9fe80000" sysupgrade -n -F openwrt-...-yuncore_...-squashfs-sysupgrade.bin In case your device runs firmware with YunCore custom GUI, you can use U-Boot recovery mode: 1. Set a static IP 192.168.0.141/24 on PC and start TFTP server with 'tftp' image renamed to 'upgrade.bin' 2. Power the device with reset button pressed and release it after 5-7 seconds, recovery mode should start downloading image from server (unfortunately, there is no visible indication that recovery got enabled - in case of problems check TFTP server logs) Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org> (cherry picked from commit c91df224f54fdd44c9c0487a8c91876f5d273164)
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 769c0ee1da..33a72358b3 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -2528,6 +2528,17 @@ define Device/yuncore_a782
endef
TARGET_DEVICES += yuncore_a782
+define Device/yuncore_xd3200
+ SOC := qca9563
+ DEVICE_VENDOR := YunCore
+ DEVICE_MODEL := XD3200
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ IMAGE_SIZE := 16000k
+ IMAGES += tftp.bin
+ IMAGE/tftp.bin := $$(IMAGE/sysupgrade.bin) | yuncore-tftp-header-16m
+endef
+TARGET_DEVICES += yuncore_xd3200
+
define Device/yuncore_xd4200
SOC := qca9563
DEVICE_VENDOR := YunCore