aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorVincent Wiemann <vincent.wiemann@ironai.com>2021-06-20 16:56:21 +0200
committerDavid Bauer <mail@david-bauer.net>2021-07-28 13:48:15 +0200
commit55b4b3655263984b92e4b9fc515a5e6b8003c655 (patch)
tree5bfb35bf76b471e6f8275b0747059404fd1e3c29 /target/linux/ath79/image
parentf1b98fa4fa8a86a9daf2a7177235f28cbd7c53ef (diff)
downloadupstream-55b4b3655263984b92e4b9fc515a5e6b8003c655.tar.gz
upstream-55b4b3655263984b92e4b9fc515a5e6b8003c655.tar.bz2
upstream-55b4b3655263984b92e4b9fc515a5e6b8003c655.zip
ath79: add support for Joy-IT JT-OR750i
Specifications: * QCA9531, 16 MiB flash (Winbond W25Q128JVSQ), 128 MiB RAM * 802.11n 2T2R (external antennas) * QCA9887, 802.11ac 1T1R (connected with diplexer to one of the antennas) * 3x 10/100 LAN, 1x 10/100 WAN * UART header with pinout printed on PCB Installation: * The device comes with a bootloader installed only * The bootloader offers DHCP and is reachable at http://10.123.123.1 * Accept the agreement and flash sysupgrade.bin * Use Firefox if flashing does not work TFTP recovery with static IP: * Rename sysupgrade.bin to jt-or750i_firmware.bin * Offer it via TFTP server at 192.168.0.66 * Keep the reset button pressed for 4 seconds after connecting power TFTP recovery with dynamic IP: * Rename sysupgrade.bin to jt-or750i_firmware.bin * Offer it via TFTP server with a DHCP server running at the same address * Keep the reset button pressed for 6 seconds after connecting power Co-authored-by: Sebastian Schaper <openwrt@sebastianschaper.net> Signed-off-by: Vincent Wiemann <vincent.wiemann@ironai.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index fbcc9d186a..b33a578f19 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1369,6 +1369,15 @@ define Device/jjplus_ja76pf2
endef
TARGET_DEVICES += jjplus_ja76pf2
+define Device/joyit_jt-or750i
+ SOC := qca9531
+ DEVICE_VENDOR := Joy-IT
+ DEVICE_MODEL := JT-OR750i
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9887-ct
+ IMAGE_SIZE := 16000k
+endef
+TARGET_DEVICES += joyit_jt-or750i
+
define Device/librerouter_librerouter-v1
SOC := qca9558
DEVICE_VENDOR := Librerouter