aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorJohn Marrett <johnf@zioncluster.ca>2021-06-08 12:57:28 -0400
committerDavid Bauer <mail@david-bauer.net>2021-08-05 01:48:17 +0200
commit252466a0ced3ec9f58b213ffd34a900fe3834cab (patch)
tree05ef28e494dd1f7653b2018c93e9f3b3f29be592 /target/linux/ath79/image
parent13d6d27422da7efa2f6c731cf742ffd1bdbb2561 (diff)
downloadupstream-252466a0ced3ec9f58b213ffd34a900fe3834cab.tar.gz
upstream-252466a0ced3ec9f58b213ffd34a900fe3834cab.tar.bz2
upstream-252466a0ced3ec9f58b213ffd34a900fe3834cab.zip
ath79: add support for GL.iNet GL-X300B
The GL-X300B is a industrial 4G LTE router based on the Qualcomm QCA9531 SoC. Specifications: - Qualcomm QCA9531 @ 650 MHz - 128 MB of RAM - 16 MB of SPI NOR FLASH - 2x 10/100 Mbps Ethernet - 2.4GHz 802.11b/g/n - 1x USB 2.0 (vbus driven by GPIO) - 4x LED, driven by GPIO - 1x button (reset) - 1x mini pci-e slot (vcc driven by GPIO) - RS-485 Serial Port (untested) Flash instructions: This firmware can be flashed using either sysupgrade from the GL.iNet firmware or the recovery console as follows: - Press and hold the reset button - Connect power to the router, wait five seconds - Manually configure 192.168.1.2/24 on your computer, connect to 192.168.1.1 - Upload the firmware image using the web interface RS-485 serial port is untested and may depend on the following commit in the GL.iNet repo: https://github.com/gl-inet/openwrt/commit/202e83a32ae308fbb70502b6dbe3bb0bf8b1fba9 MAC addresses as verified by OEM firmware: vendor OpenWrt address WAN eth0 label LAN eth1 label + 1 2g phy0 label + 2 The label MAC address was found in the art partition at 0x0 Based on vendor commit: https://github.com/gl-inet/openwrt/commit/16c5708b207eb76ff19a040dc973e560d3d8074b Signed-off-by: John Marrett <johnf@zioncluster.ca>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index b33a578f19..2abe1b7307 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1243,6 +1243,15 @@ define Device/glinet_gl-usb150
endef
TARGET_DEVICES += glinet_gl-usb150
+define Device/glinet_gl-x300b
+ SOC := qca9531
+ DEVICE_VENDOR := GL.iNet
+ DEVICE_MODEL := GL-X300B
+ DEVICE_PACKAGES := kmod-usb2
+ IMAGE_SIZE := 16000k
+endef
+TARGET_DEVICES += glinet_gl-x300b
+
define Device/glinet_gl-x750
SOC := qca9531
DEVICE_VENDOR := GL.iNet