aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorShiji Yang <yangshiji66@qq.com>2021-09-29 00:25:01 +0800
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-11-01 00:15:09 +0100
commit184dc6e32a4d2e22d916b709fdea69e1512889a7 (patch)
treefc8e9dd1eb7be496e1d738d9468a60f0a3a3b585 /target/linux/ath79/image
parent84451173f08e7af9e47c85c1a0cd8e041f4ec568 (diff)
downloadupstream-184dc6e32a4d2e22d916b709fdea69e1512889a7.tar.gz
upstream-184dc6e32a4d2e22d916b709fdea69e1512889a7.tar.bz2
upstream-184dc6e32a4d2e22d916b709fdea69e1512889a7.zip
ath79: add support for Letv LBA-047-CH
Specifications: SOC: QCA9531 650 MHz ROM: 16 MiB Flash (Winbond W25Q128FV) RAM: 128 MiB DDR2 (Winbond W971GG6SB) LAN: 10/100M *2 WAN: 10/100M *1 LED: BGR color *1 Mac address: label C8:0E:77:xx:xx:68 art@0x0 lan C8:0E:77:xx:xx:62 art@0x6 wan C8:0E:77:xx:xx:68 art@0x0 (same as the label) wlan C8:0E:77:xx:xx:B2 art@0x1002 (load automatically) TFTP installation: * Set local IP to 192.168.67.100 and open tftpd64, link lan port to computer. Rename "xxxx-factory.bin" to "openwrt-ar71xx-generic-ap147-16M-rootfs-squashfs.bin". * Make sure firmware file is in the tftpd's directory, push reset button and plug in, hold it for 5 seconds, and then it will download firmware from tftp server automatically. More information: * This device boot from flash@0xe80000 so we need a okli loader to deal with small kernel partition issue. In order to make full use of the storage space, connect a part of the previous kernel partition to the firmware. Stock Modify 0x000000-0x040000(u-boot) 0x000000-0x040000(u-boot) 0x040000-0x050000(u-boot-env) 0x000000-0x050000(u-boot-env) 0x050000-0xe80000(rootfs) 0x050000-0xe80000(firmware part1) 0xe80000-0xff0000(kernel) 0xe80000-0xe90000(okli-loader) 0xe90000-0xff0000(firmware part2) 0xff0000-0x1000000(art) 0xff0000-0x1000000(art) Signed-off-by: Shiji Yang <yangshiji66@qq.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index b170323394..fb393ba082 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1414,6 +1414,21 @@ define Device/joyit_jt-or750i
endef
TARGET_DEVICES += joyit_jt-or750i
+define Device/letv_lba-047-ch
+ $(Device/loader-okli-uimage)
+ SOC := qca9531
+ DEVICE_VENDOR := Letv
+ DEVICE_MODEL := LBA-047-CH
+ IMAGE_SIZE := 15936k
+ LOADER_FLASH_OFFS := 0x50000
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | check-size | pad-to 14528k | \
+ append-loader-okli-uimage $(1) | pad-to 64k
+endef
+TARGET_DEVICES += letv_lba-047-ch
+
define Device/librerouter_librerouter-v1
SOC := qca9558
DEVICE_VENDOR := Librerouter