aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2022-02-17 23:22:25 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2022-02-27 16:54:54 +0100
commit131671bc54dff89c33c10241b8fca8fa34a9b2bf (patch)
tree1ede76b4dfe411e27a4fb2e9b253248bb582eb52 /target/linux/ath79/image
parent53ac6ee552baca52f3f18fc95b793c03e1bf9581 (diff)
downloadupstream-131671bc54dff89c33c10241b8fca8fa34a9b2bf.tar.gz
upstream-131671bc54dff89c33c10241b8fca8fa34a9b2bf.tar.bz2
upstream-131671bc54dff89c33c10241b8fca8fa34a9b2bf.zip
ath79: add support for ALFA Network Tube-2HQ
ALFA Network Tube-2HQ is a successor of the Tube-2H/P series (EOL) which was based on the Atheros AR9331. The new version uses Qualcomm QCA9531. Specifications: - Qualcomm/Atheros QCA9531 v2 - 650/400/200 MHz (CPU/DDR/AHB) - 64 or 128 MB of RAM (DDR2) - 16+ MB of flash (SPI NOR) - 1x 10/100 Mbps Ethernet with passive PoE input (24 V) (802.3at/af PoE support with optional module) - 1T1R 2.4 GHz Wi-Fi with external PA (SE2623L, up to 27 dBm) and LNA - 1x Type-N (male) antenna connector - 6x LED (5x driven by GPIO) - 1x button (reset) - external h/w watchdog (EM6324QYSP5B, enabled by default) - UART (4-pin, 2.00 mm pitch) header on PCB Flash instruction: You can use sysupgrade image directly in vendor firmware which is based on LEDE/OpenWrt. Alternatively, you can use web recovery mode in U-Boot: 1. Configure PC with static IP 192.168.1.2/24. 2. Connect PC with one of RJ45 ports, press the reset button, power up device, wait for first blink of all LEDs (indicates network setup), then keep button for 3 following blinks and release it. 3. Open 192.168.1.1 address in your browser and upload sysupgrade image. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index b01eff7d0b..27a9860d28 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -298,6 +298,16 @@ define Device/alfa-network_r36a
endef
TARGET_DEVICES += alfa-network_r36a
+define Device/alfa-network_tube-2hq
+ SOC := qca9531
+ DEVICE_VENDOR := ALFA Network
+ DEVICE_MODEL := Tube-2HQ
+ DEVICE_PACKAGES := rssileds -swconfig
+ IMAGE_SIZE := 15872k
+ SUPPORTED_DEVICES += tube-2hq
+endef
+TARGET_DEVICES += alfa-network_tube-2hq
+
define Device/allnet_all-wap02860ac
$(Device/senao_loader_okli)
SOC := qca9558