aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorAlex Henrie <alexhenrie24@gmail.com>2022-02-20 18:21:38 -0700
committerPetr Štetiar <ynezz@true.cz>2022-02-26 13:36:30 +0100
commitfe1ecf1fcbc00642b60f00f95640c17787cc9c62 (patch)
tree4d6e8243dea706885b4bac4acfda16ae91423cd2 /target/linux/ath79/image
parent4e28494144d2806e33fba6ebb452dd418046ed1a (diff)
downloadupstream-fe1ecf1fcbc00642b60f00f95640c17787cc9c62.tar.gz
upstream-fe1ecf1fcbc00642b60f00f95640c17787cc9c62.tar.bz2
upstream-fe1ecf1fcbc00642b60f00f95640c17787cc9c62.zip
ath79: add Zyxel EMG2926-Q10A
The Zyxel EMG2926-Q10A is 99% the Zyxel NBG6716, but the bootloader expects a different product name when flashing over TFTP. Also, the EMG2926-Q10A always has 128 MiB of NAND flash whereas the NBG6716 reportedly can have either 128 MiB or 256 MiB. Signed-off-by: Alex Henrie <alexhenrie24@gmail.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/nand.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index 2d7892db94..9f209368e4 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -344,3 +344,10 @@ define Device/zyxel_nbg6716
UBINIZE_OPTS := -E 5
endef
TARGET_DEVICES += zyxel_nbg6716
+
+define Device/zyxel_emg2926_q10a
+ $(Device/zyxel_nbg6716)
+ DEVICE_MODEL := EMG2926-Q10A
+ RAS_BOARD := AAVK-EMG2926Q10A
+endef
+TARGET_DEVICES += zyxel_emg2926_q10a