aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2022-01-31 13:21:47 +0900
committerSungbo Eo <mans0n@gorani.run>2022-02-01 14:54:16 +0900
commitc7a559980ad18270c0c1c7afa4cbe708f26fb851 (patch)
treeca133216b20cbe59f6e3522a4d9bcd1b2d9ef732 /target/linux/ath79/image
parent0c635cf830bc9bb46005f5f8ac414c80e1bcab4e (diff)
downloadupstream-c7a559980ad18270c0c1c7afa4cbe708f26fb851.tar.gz
upstream-c7a559980ad18270c0c1c7afa4cbe708f26fb851.tar.bz2
upstream-c7a559980ad18270c0c1c7afa4cbe708f26fb851.zip
ath79: improve support for Dongwon T&I DW02-412H
* Move &nand node to DTSI * Utilize nvmem for fetching caldata * Rename build recipe, clean before build * Simplify KERNEL definition Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/nand.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index b8006c6d0c..1e1152551b 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -1,7 +1,7 @@
-define Build/dw-headers
- head -c 4 $@ >> $@.tmp && \
- head -c 8 /dev/zero >> $@.tmp && \
- tail -c +9 $@ >> $@.tmp && \
+define Build/dongwon-header
+ head -c 4 $@ > $@.tmp
+ head -c 8 /dev/zero >> $@.tmp
+ tail -c +9 $@ >> $@.tmp
( \
header_crc="$$(head -c 68 $@.tmp | gzip -c | \
tail -c 8 | od -An -N4 -tx4 --endian little | tr -d ' \n')"; \
@@ -99,8 +99,8 @@ define Device/dongwon_dw02-412h
KERNEL_SIZE := 8192k
BLOCKSIZE := 128k
PAGESIZE := 2048
- KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | dw-headers
- KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma | dw-headers
+ KERNEL := $$(KERNEL) | dongwon-header
+ KERNEL_INITRAMFS := $$(KERNEL)
UBINIZE_OPTS := -E 5
IMAGES += factory.img
IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | \