aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorOlivier Valentin <valentio@free.fr>2021-12-02 17:05:18 +0100
committerChristian Lamparter <chunkeey@gmail.com>2021-12-11 00:50:02 +0100
commit7853453950bf47b518673dc50b61903cd48c9081 (patch)
treedf9fed5ec78e2d04f3c066394cd6602648aa0bb7 /target/linux/ath79/image
parent4deaeaa13cbcd3c4b94c69e96d7e507f201ea4cc (diff)
downloadupstream-7853453950bf47b518673dc50b61903cd48c9081.tar.gz
upstream-7853453950bf47b518673dc50b61903cd48c9081.tar.bz2
upstream-7853453950bf47b518673dc50b61903cd48c9081.zip
ath79: add support for jjPlus JWAP230
The jjPlus JWAP230 is an access point board built around the QCA9558, with built-in 2.4GHz 3x3 N WiFi (28dBm). It can be expanded with 2 mini-PCIe boards, and has an USB2 root port. Specifications: - SOC: Qualcomm Atheros QCA9558 - CPU: 720MHz - H/W switch: QCA8327 rev 2 - Flash: 16 MiB SPI NOR (en25qh128) - RAM: 128 MiB DDR2 - WLAN: AR9550 built-in SoC bgn 3T3R (ath9k) - PCI: 2x mini-PCIe (optional 5V) - LEDs: 6x LEDs (3 are currently available) - Button: 1x Reset (not yet defined) - USB2: - 1x Type A root port - 1x combined mini-PCIe - Ethernet: - 2x 10/100/1000 (1x PoE 802.3af (36-57 V)) Notes: The device used to be supported in the ar71xx target. For upgrades: Please use "sysupgrade --force -n <image>". This will restore the device back to OpenWrt defaults! MAC address assignment: use source LAN art 0x0 WAN art 0x6 WLAN art 0x1002 (as part of the calibration data) Flash instructions: - install from u-boot with tftp (requires serial access) > setenv ipaddr a.b.c.d > setenv serverip e.f.g.h > tftp 0x80060000 \ openwrt-ath79-generic-jjplus_jwap230-squashfs-sysupgrade.bin > erase 0x9f050000 +${filesize} > cp.b $fileaddr 0x9f050000 $filesize > setenv bootcmd bootm 0x9f050000 > saveenv Signed-off-by: Olivier Valentin <valentio@free.fr> [Added DT-Leds (based on ar71xx), Added more notes about sysupgrade, fixed "qca9550" to match SoC in commit and dts file name] Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index c259db94af..cff4b98eae 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1407,6 +1407,14 @@ define Device/jjplus_ja76pf2
endef
TARGET_DEVICES += jjplus_ja76pf2
+define Device/jjplus_jwap230
+ SOC := qca9558
+ DEVICE_VENDOR := jjPlus
+ DEVICE_MODEL := JWAP230
+ IMAGE_SIZE := 16000k
+endef
+TARGET_DEVICES += jjplus_jwap230
+
define Device/joyit_jt-or750i
SOC := qca9531
DEVICE_VENDOR := Joy-IT