aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorDaniel González Cabanelas <dgcbueu@gmail.com>2022-01-16 19:00:19 +0100
committerPetr Štetiar <ynezz@true.cz>2022-02-19 13:10:01 +0100
commit73ea763c0dcdb96c9163790f20edd964399035c0 (patch)
tree2080eec504e24e018d7c7de80f8f181ba9874210 /target/linux/ath79/image
parent66071729a27919e555752fce25210b1b035eb319 (diff)
downloadupstream-73ea763c0dcdb96c9163790f20edd964399035c0.tar.gz
upstream-73ea763c0dcdb96c9163790f20edd964399035c0.tar.bz2
upstream-73ea763c0dcdb96c9163790f20edd964399035c0.zip
ath79: Add support for Ubiquiti NanoBeam AC Gen1 XC
The Ubiquiti NanoBeam AC Gen1 XC (NBE-5AC-19) is an outdoor 802.11ac CPE with a waterproof casing (ultrasonically welded) and bulb shaped. Hardware: - SoC: Qualcomm Atheros QCA9558 - RAM: 128 MB DDR2 - Flash: 16 MB SPI NOR - Ethernet: 1x GbE, AR8033 phy connected via SGMII - PSU: 24 Vdc passive PoE - WiFi 5 GHz: Qualcomm Atheros QCA988X - Buttons: 1x reset - LEDs: 1x power, 1x Ethernet, 4x RSSI, all blue - Internal antenna: 19 dBi planar Installation from stock airOS firmware: - Follow instructions for XC-type Ubiquiti devices on OpenWrt wiki at https://openwrt.org/toh/ubiquiti/common Signed-off-by: Daniel González Cabanelas <dgcbueu@gmail.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index bb5eaa5458..9470adf48b 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -246,6 +246,15 @@ define Device/ubnt_nanobeam-ac-gen2
endef
TARGET_DEVICES += ubnt_nanobeam-ac-gen2
+define Device/ubnt_nanobeam-ac-xc
+ $(Device/ubnt-xc)
+ SOC := qca9558
+ DEVICE_MODEL := NanoBeam AC
+ DEVICE_VARIANT := Gen1 (XC)
+ DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct rssileds
+endef
+TARGET_DEVICES += ubnt_nanobeam-ac-xc
+
define Device/ubnt_nanobridge-m
$(Device/ubnt-xm)
SOC := ar7241