aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorCatrinel Catrinescu <cc@80211.de>2021-12-02 10:07:54 +0000
committerChristian Lamparter <chunkeey@gmail.com>2021-12-03 12:30:08 +0100
commit24d455d1d0adf64de844b25800c23992aa3eeda5 (patch)
treefa9cbc391a9202a01f58569b837dc874304e5dc0 /target/linux/ath79/image
parent8ac8c09f5ebbb6ae5e73b8a8ff4b095c1154f707 (diff)
downloadupstream-24d455d1d0adf64de844b25800c23992aa3eeda5.tar.gz
upstream-24d455d1d0adf64de844b25800c23992aa3eeda5.tar.bz2
upstream-24d455d1d0adf64de844b25800c23992aa3eeda5.zip
ath79: add Embedded Wireless Balin Platform
Add the Embedded Wireless "Balin" platform, it is in ar71xx too SoC: QCA AR9344 or AR9350 RAM: DDR2-RAM 64MBytes Flash: SPI-NOR 16MBytes WLAN: 2 x 2 MIMO 2.4 & 5 GHz IEEE802.11 a/b/g/n Ethernet: 3 x 10/100 Mb/s USB: 1 x USB2.0 Host/Device bootstrap-pin at power-up PCIe: MiniPCIe - 1 x lane PCIe 1.2 Button: 1 x Reset-Button UART: 1 x Normal, 1 x High-Speed JTAG: 1 x EJTAG LED: 1 x Green Power/Status LED GPIO: 10 x Input/Output multiplexed The module comes already with the current vanilla OpenWrt firmware. To update, use "sysupgrade -n --force <image>" image directly in vendor firmware. This resets the existing configurations back to default! Signed-off-by: Catrinel Catrinescu <cc@80211.de> [indent, led function+color properties, fix partition unit-address, re-enable pcie port, mention button+led in commit message] Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 39f616b010..c259db94af 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1028,6 +1028,15 @@ define Device/elecom_wrc-300ghbk2-i
endef
TARGET_DEVICES += elecom_wrc-300ghbk2-i
+define Device/embeddedwireless_balin
+ SOC := ar9344
+ DEVICE_VENDOR := Embedded Wireless
+ DEVICE_MODEL := Balin
+ DEVICE_PACKAGES := kmod-usb-chipidea2
+ IMAGE_SIZE := 16000k
+endef
+TARGET_DEVICES += embeddedwireless_balin
+
define Device/embeddedwireless_dorin
SOC := ar9331
DEVICE_VENDOR := Embedded Wireless