aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorThibaut VARÈNE <hacks@slashdirt.org>2022-03-10 12:01:29 +0100
committerPetr Štetiar <ynezz@true.cz>2022-04-16 14:51:57 +0200
commit9a765554f409235ff6359d6eccb79187c2513de0 (patch)
treec2bedabb1167a856ae01a9ac2dec4c6182b8ea11 /target/linux/ath79/image
parent2cc9ee8000597fe132071ec3ba6bf0ac9404ac94 (diff)
downloadupstream-9a765554f409235ff6359d6eccb79187c2513de0.tar.gz
upstream-9a765554f409235ff6359d6eccb79187c2513de0.tar.bz2
upstream-9a765554f409235ff6359d6eccb79187c2513de0.zip
ath79: add support for MikroTik RouterBOARD mAP lite
The MikroTik RouterBOARD mAPL-2nd (sold as mAP Lite) is a small 2.4 GHz 802.11b/g/n PoE-capable AP. See https://mikrotik.com/product/RBmAPL-2nD for more info. Specifications: - SoC: Qualcomm Atheros QCA9533 - RAM: 64 MB - Storage: 16 MB NOR - Wireless: Atheros AR9531 (SoC) 802.11b/g/n 2x2:2, 1.5 dBi antenna - Ethernet: Atheros AR8229 (SoC), 1x 10/100 port, 802.3af/at PoE in - 4 user-controllable LEDs: · 1x power (green) · 1x user (green) · 1x lan (green) · 1x wlan (green) Flashing: TFTP boot initramfs image and then perform sysupgrade. Follow common MikroTik procedure as in https://openwrt.org/toh/mikrotik/common. Note: following 781d4bfb397cdd12ee0151eb66c577f470e3377d The network setup avoids using the integrated switch and connects the single Ethernet port directly. This way, link speed (10/100 Mbps) is properly reported by eth0. Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org> (cherry picked from commit eb38af788180d624e5b37aa5db1fe3766b138dc8)
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/mikrotik.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/mikrotik.mk b/target/linux/ath79/image/mikrotik.mk
index 4256f77379..b2c7000419 100644
--- a/target/linux/ath79/image/mikrotik.mk
+++ b/target/linux/ath79/image/mikrotik.mk
@@ -45,6 +45,14 @@ define Device/mikrotik_routerboard-lhg-2nd
endef
TARGET_DEVICES += mikrotik_routerboard-lhg-2nd
+define Device/mikrotik_routerboard-mapl-2nd
+ $(Device/mikrotik_nor)
+ SOC := qca9533
+ DEVICE_MODEL := RouterBOARD mAPL-2nD (mAP lite)
+ IMAGE_SIZE := 16256k
+endef
+TARGET_DEVICES += mikrotik_routerboard-mapl-2nd
+
define Device/mikrotik_routerboard-sxt-5nd-r2
$(Device/mikrotik_nand)
SOC := ar9344