aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2020-10-09 07:30:24 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2020-11-18 23:49:34 +0100
commit64a6f4a9c1553a968969fb8821f558c875187acc (patch)
tree3b22b11e7a01960a55a91f14cb346b9654aebae4 /target/linux/ath79/image
parentd44463b087839ea9b31da2411447e85befbd9ec7 (diff)
downloadupstream-64a6f4a9c1553a968969fb8821f558c875187acc.tar.gz
upstream-64a6f4a9c1553a968969fb8821f558c875187acc.tar.bz2
upstream-64a6f4a9c1553a968969fb8821f558c875187acc.zip
ath79: add support for ALFA Network Pi-WiFi4
ALFA Network Pi-WiFi4 is a Qualcomm QCA9531 v2 based, high-power 802.11n WiFi board in Raspberry Pi 3B shape, equipped with 1x FE and 4x USB 2.0. Specifications: - Qualcomm/Atheros QCA9531 v2 - 650/400/200 MHz (CPU/DDR/AHB) - 128 MB of RAM (DDR2) - 16+ MB of flash (SPI NOR) - 1x 10/100 Mbps Ethernet - 2T2R 2.4 GHz Wi-Fi with Qorvo RFFM8228P FEM - 2x IPEX/U.FL connectors on PCB - 4x USB 2.0 Type-A - Genesys Logic GL850G 4-port USB HUB - USB power is controlled by GPIO - 5x LED (3x on PCB, 2x in RJ45, 4x driven by GPIO) - 1x button (reset) - external h/w watchdog (EM6324QYSP5B, enabled by default) - 1x micro USB Type-B for power and system console (Holtek HT42B534) - UART and GPIO (8-pin, 1.27 mm pitch) header on PCB Flash instruction: You can use sysupgrade image directly in vendor firmware which is based on LEDE/OpenWrt. Alternatively, you can use web recovery mode in U-Boot: 1. Configure PC with static IP 192.168.1.2/24. 2. Connect PC with one of RJ45 ports, press the reset button, power up device, wait for first blink of all LEDs (indicates network setup), then keep button for 3 following blinks and release it. 3. Open 192.168.1.1 address in your browser and upload sysupgrade image. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index dc91e1b6d9..fc8b136c51 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -257,6 +257,15 @@ define Device/alfa-network_n5q
endef
TARGET_DEVICES += alfa-network_n5q
+define Device/alfa-network_pi-wifi4
+ SOC := qca9531
+ DEVICE_VENDOR := ALFA Network
+ DEVICE_MODEL := Pi-WiFi4
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport -swconfig
+ IMAGE_SIZE := 15872k
+endef
+TARGET_DEVICES += alfa-network_pi-wifi4
+
define Device/alfa-network_r36a
SOC := qca9531
DEVICE_VENDOR := ALFA Network