aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-04-12 13:33:01 +0200
committerDavid Bauer <mail@david-bauer.net>2020-04-17 13:27:40 +0200
commit8918c038f330a1bb5a898d80c170caf9f42cac89 (patch)
tree260be3b1073f927d1230430c5a8da073a22327a5 /target/linux/ath79/image
parentd883eaacd428e1231554687e9875248291a004cc (diff)
downloadupstream-8918c038f330a1bb5a898d80c170caf9f42cac89.tar.gz
upstream-8918c038f330a1bb5a898d80c170caf9f42cac89.tar.bz2
upstream-8918c038f330a1bb5a898d80c170caf9f42cac89.zip
ath79: add support for AVM FRITZ!WLAN Repeater 1750E
This commit adds support for the AVM Fritz!WLAN Repeater 1750E SOC: Qualcomm QCA9556 (Scorpion) 720MHz MIPS74Kc RAM: 64MB Zentel A3R12E40CBF DDR2 FLASH: 16MiB Winbond W25Q128 SPI NOR WLAN1: QCA9556 2.4 GHz 802.11b/g/n 3x3 WLAN2: QCA9880 5 GHz 802.11 n/ac 3x3 INPUT: WPS button LED: Power, WiFi, LAN, RSSI indicator Serial: Header Next to Black metal shield Pinout is 3.3V - RX - TX - GND (Square Pad is 3.3V) The Serial setting is 115200-8-N-1. Tested and working: - Ethernet - 2.4 GHz WiFi (correct MAC) - 5 GHz WiFi (correct MAC) - Installation via EVA bootloader - OpenWRT sysupgrade - Buttons - LEDs Installation via EVA: In the first seconds after Power is connected, the bootloader will listen for FTP connections on 192.168.178.1. Firmware can be uploaded like following: ftp> quote USER adam2 ftp> quote PASS adam2 ftp> binary ftp> debug ftp> passive ftp> quote MEDIA FLSH ftp> put openwrt-sysupgrade.bin mtd1 Note that this procedure might take up to two minutes. You need to powercycle the Device afterwards to boot OpenWRT. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk35
1 files changed, 22 insertions, 13 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 69067c9de0..aebb519164 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -162,32 +162,41 @@ define Device/aruba_ap-105
endef
TARGET_DEVICES += aruba_ap-105
-define Device/avm_fritz300e
- SOC := ar7242
+define Device/avm
DEVICE_VENDOR := AVM
- DEVICE_MODEL := FRITZ!WLAN Repeater 300E
KERNEL := kernel-bin | append-dtb | lzma | eva-image
KERNEL_INITRAMFS := $$(KERNEL)
- IMAGE_SIZE := 15232k
IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | \
append-squashfs-fakeroot-be | pad-to 256 | append-rootfs | pad-rootfs | \
append-metadata | check-size
- DEVICE_PACKAGES := fritz-tffs rssileds -swconfig
+ DEVICE_PACKAGES := fritz-tffs
+endef
+
+define Device/avm_fritz1750e
+ $(Device/avm)
+ SOC := qca9556
+ IMAGE_SIZE := 15232k
+ DEVICE_MODEL := FRITZ!WLAN Repeater 1750E
+ DEVICE_PACKAGES += rssileds kmod-ath10k-ct-smallbuffers | \
+ ath10k-firmware-qca988x-ct -swconfig
+endef
+TARGET_DEVICES += avm_fritz1750e
+
+define Device/avm_fritz300e
+ $(Device/avm)
+ SOC := ar7242
+ IMAGE_SIZE := 15232k
+ DEVICE_MODEL := FRITZ!WLAN Repeater 300E
+ DEVICE_PACKAGES += rssileds -swconfig
SUPPORTED_DEVICES += fritz300e
endef
TARGET_DEVICES += avm_fritz300e
define Device/avm_fritz4020
+ $(Device/avm)
SOC := qca9561
- DEVICE_VENDOR := AVM
- DEVICE_MODEL := FRITZ!Box 4020
IMAGE_SIZE := 15232k
- KERNEL := kernel-bin | append-dtb | lzma | eva-image
- KERNEL_INITRAMFS := $$(KERNEL)
- IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | \
- append-squashfs-fakeroot-be | pad-to 256 | append-rootfs | pad-rootfs | \
- append-metadata | check-size
- DEVICE_PACKAGES := fritz-tffs
+ DEVICE_MODEL := FRITZ!Box 4020
SUPPORTED_DEVICES += fritz4020
endef
TARGET_DEVICES += avm_fritz4020