aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorAndreas Ziegler <dev@andreas-ziegler.de>2019-10-06 19:48:34 +0200
committerDavid Bauer <mail@david-bauer.net>2019-10-27 18:31:53 +0100
commit8cf67728d3b41c47ee5e322bb8c2908696380f24 (patch)
treed710b134306d7129aeec9428145e3d9a45780512 /target/linux/ath79/image
parentb7ee43ecac53740d7c91c68eb1d3a421c1f1acb9 (diff)
downloadupstream-8cf67728d3b41c47ee5e322bb8c2908696380f24.tar.gz
upstream-8cf67728d3b41c47ee5e322bb8c2908696380f24.tar.bz2
upstream-8cf67728d3b41c47ee5e322bb8c2908696380f24.zip
ath79: add support for UniFi AC-LR
The Unifi AC-LR has identical hardware to the Unifi AC-Lite. The antenna setup is different according to the vendor, which explains the thicker enclosure. Therefore, it is helpful to know the exact device variant, instead of having "Ubiquiti UniFi-AC-LITE/LR". Signed-off-by: Andreas Ziegler <dev@andreas-ziegler.de> [fix legacy name in commit message; add old boardname to SUPPORTED_DEVICES] Signed-off-by: David Bauer <mail@david-bauer.net> (cherry picked from commit 07c1ddf522dbe6085af664cf03a41f636a70b99c) Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index c51d743a35..fdc0d28033 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -177,6 +177,13 @@ define Device/ubnt_unifiac-lite
endef
TARGET_DEVICES += ubnt_unifiac-lite
+define Device/ubnt_unifiac-lr
+ $(Device/ubnt_unifiac)
+ DEVICE_TITLE := Ubiquiti UniFi AC-LR
+ SUPPORTED_DEVICES += unifiac-lite ubnt,unifiac-lite
+endef
+TARGET_DEVICES += ubnt_unifiac-lr
+
define Device/ubnt_unifiac-mesh
$(Device/ubnt_unifiac)
DEVICE_TITLE := Ubiquiti UniFi AC-Mesh