aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-08-05 17:51:16 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-13 17:33:20 +0100
commitfbd00bb8d406a0ace7ea9c49a79cbad2418689a5 (patch)
tree9e65be03bc2ad87c6c77671332d13d476553f31d /target/linux/ath79/image
parent49ff00db340ea017c266ba37546c71209cfe3e26 (diff)
downloadupstream-fbd00bb8d406a0ace7ea9c49a79cbad2418689a5.tar.gz
upstream-fbd00bb8d406a0ace7ea9c49a79cbad2418689a5.tar.bz2
upstream-fbd00bb8d406a0ace7ea9c49a79cbad2418689a5.zip
ath79: add support for TP-Link TL-WR940N v6
The TL-WR940N v6 is similar to v3/v4, it just has different LEDs and MAC address assignment. Specification: - 750 MHz CPU - 32 MB of RAM - 4 MB of FLASH - 2.4 GHz WiFi - 4x 10/100 Mbps Ethernet The use of LEDs is based on ar71xx, so blue LED is used for WAN and orange LED for diag (boot/failsafe/etc.). Flash instruction (WebUI): Download *-factory.bin image and upload it via the firmwary upgrade function of the stock firmware WebUI. Flash instruction (TFTP): 1. Set PC to fixed ip address 192.168.0.66 2. Download *-factory.bin image and rename it to wr940nv6_tp_recovery.bin 3. Start a tftp server with the image file in its root directory 4. Turn off the router 5. Press and hold Reset button 6. Turn on router with the reset button pressed and wait ~15 seconds 7. Release the reset button and after a short time the firmware should be transferred from the tftp server 8. Wait ~30 second to complete recovery. Thanks to Manuel Kock for reviewing and testing this patch. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Tested-by: Manuel Kock <github.web@manu.li>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index 787ac055ba..8f6f2fe14a 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -274,6 +274,20 @@ define Device/tplink_tl-wr940n-v4
endef
TARGET_DEVICES += tplink_tl-wr940n-v4
+define Device/tplink_tl-wr940n-v6
+ $(Device/tplink-4mlzma)
+ SOC := tp9343
+ DEVICE_MODEL := TL-WR940N
+ DEVICE_VARIANT := v6
+ TPLINK_HWID := 0x09400006
+ SUPPORTED_DEVICES += tl-wr940n-v6
+ IMAGES += factory-us.bin factory-eu.bin factory-br.bin
+ IMAGE/factory-us.bin := tplink-v1-image factory -C US
+ IMAGE/factory-eu.bin := tplink-v1-image factory -C EU
+ IMAGE/factory-br.bin := tplink-v1-image factory -C BR
+endef
+TARGET_DEVICES += tplink_tl-wr940n-v6
+
define Device/tplink_tl-wr941-v2
$(Device/tplink-4m)
SOC := ar9132