aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorJeff Kletsky <git-commits@allycomm.com>2019-11-13 13:09:49 -0800
committerJohn Crispin <john@phrozen.org>2020-01-15 20:06:02 +0100
commite96bfaedf3a342750d92fbfa773017e40e34bec3 (patch)
tree1af29278c5f98ddbb53885ef9db5d4236338a2bc /target/linux/ath79/image
parentf0b76d02e8345022d417f02733504cfd862a2d6f (diff)
downloadupstream-e96bfaedf3a342750d92fbfa773017e40e34bec3.tar.gz
upstream-e96bfaedf3a342750d92fbfa773017e40e34bec3.tar.bz2
upstream-e96bfaedf3a342750d92fbfa773017e40e34bec3.zip
ath79: GL-AR750S (NOR/NAND): limit factory.img kernel size to 2 MB
The present U-Boot for GL-AR750S has a limit of 2 MB for kernel size. While sysupgrade can manage kernels up to the present limit of 4 MB, directly flashing a factory.img with a kernel size greater than 2 MB through U-Boot will result in an unbootable device. This commit uses the newly-introduced check-kernel-size build operation to prevent the output of factory.img when the kernel exceeds 2 MB in size, yet permits output of sysupgrade.img as long as the kernel is within KERNEL_SIZE := 4096k Cc: Chuanhong Guo <gch981213@gmail.com> Signed-off-by: Jeff Kletsky <git-commits@allycomm.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/nand.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index cc775d52b6..00479e4eb5 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -88,12 +88,15 @@ define Device/glinet_gl-ar750s-common
VID_HDR_OFFSET := 2048
endef
+# NB: The kernel size is intentionally restricted at this time; see commit message
define Device/glinet_gl-ar750s-nor-nand
$(Device/glinet_gl-ar750s-common)
DEVICE_VARIANT := NOR/NAND
BLOCKSIZE := 128k
+ GL_UBOOT_UBI_OFFSET := 2048k
IMAGES += factory.img
- IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
+ IMAGE/factory.img := append-kernel | pad-to $$$$(GL_UBOOT_UBI_OFFSET) | \
+ append-ubi | check-kernel-size $$$$(GL_UBOOT_UBI_OFFSET)
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
SUPPORTED_DEVICES += glinet,gl-ar750s-nor
endef