aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorLuo chongjun <luochongjun@gl-inet.com>2018-11-05 10:03:05 +0800
committerJohn Crispin <john@phrozen.org>2018-11-26 12:05:45 +0100
commit9989fd5154fd8301bf363ddae0b5083220141865 (patch)
treefd816645a525f1f72f4bef2b7f44824f6bed363d /target/linux/ath79/image
parent987b961537b7002eda21df97dd8bfebe8882bc6d (diff)
downloadupstream-9989fd5154fd8301bf363ddae0b5083220141865.tar.gz
upstream-9989fd5154fd8301bf363ddae0b5083220141865.tar.bz2
upstream-9989fd5154fd8301bf363ddae0b5083220141865.zip
ath79: add support for GL-iNet GL-X750
this patch adds supports for GL-X750. Specification: - SOC: QCA9531 (650MHz) - Flash: 16 MiB (W25Q128FVSG) - RAM: 128 MiB DDR2 - Ethernet: 10/100: 1xLAN + 10/100: 1xWAN - Wireless: 2.4GHz (bgn) and 5GHz (ac) - USB: 1x USB 2.0 port - Button: 1x reset button - LED: 5x LEDS (green) Flash instruction: The original firmware is openwrt, so both LuCI or sysupgrade can be used. Signed-off-by: Luo chongjun <luochongjun@gl-inet.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 75e93998a9..3dbed22924 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -176,6 +176,14 @@ define Device/glinet_ar300m_nor
endef
TARGET_DEVICES += glinet_ar300m_nor
+define Device/glinet_x750
+ ATH_SOC := qca9533
+ DEVICE_TITLE := GL.iNet GL-ARX750
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ath10k ath10k-firmware-qca9887
+ IMAGE_SIZE := 16000k
+endef
+TARGET_DEVICES += glinet_x750
+
define Device/iodata_etg3-r
ATH_SOC := ar9342
DEVICE_TITLE := I-O DATA ETG3-R