aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorWeijie Gao <hackpascal@gmail.com>2018-06-13 21:14:49 +0800
committerJohn Crispin <john@phrozen.org>2018-06-18 18:21:16 +0200
commit97c5cbc496e9cf8139994cd3ea987f4e9c70adbe (patch)
tree8d04f701b5020cc5c10d17826aa522ad08279281 /target/linux/ath79/image
parent8f804f42d52e49191429ad1d716e7adb3cd10ceb (diff)
downloadupstream-97c5cbc496e9cf8139994cd3ea987f4e9c70adbe.tar.gz
upstream-97c5cbc496e9cf8139994cd3ea987f4e9c70adbe.tar.bz2
upstream-97c5cbc496e9cf8139994cd3ea987f4e9c70adbe.zip
ath79: add support for Phicomm K2T
This patch adds dts for qca956x and also support for Phicomm K2T The qca965x.dtsi adds nearly all the necessary components. Both ath9k AHB and PCIe worked well. The Phicomm K2T uses MTD partition 'config' to store the mac addresses in JSON format. To extract these fields correctly, a script is introduced: /lib/functions/k2t.sh This script provides a helper function to extract mac addresses, and is used in three places. Hardware spec of Phicomm K2T: CPU: QCA9563 DRAM: 64MB DDR2 Flash: 16MB SPI-NOR Switch: QCA8337 WiFi 5.8GHz: QCA9886 Flash instruction: Apply sysupgrade.bin via serial console: tftp 0x80000000 sysupgrade.bin && erase 0x9f090000 +$filesize && cp.b $fileaddr 0x9f090000 $filesize Signed-off-by: Weijie Gao <hackpascal@gmail.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 6e662cea46..16a3c8ed53 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -75,3 +75,17 @@ define Device/buffalo_wzr-hp-g450h
SUPPORTED_DEVICES += wzr-hp-g450h
endef
TARGET_DEVICES += buffalo_wzr-hp-g450h
+
+define Device/phicomm-k2t
+ ATH_SOC := qca9563
+ DEVICE_TITLE := Phicomm K2T
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
+ IMAGE_SIZE := 15744k
+ IMAGES := sysupgrade.bin
+ IMAGE/default := append-kernel | append-rootfs | pad-rootfs
+ IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | check-size $$$$(IMAGE_SIZE)
+ DEVICE_PACKAGES := kmod-leds-reset kmod-ath10k ath10k-firmware-qca9888
+ SUPPORTED_DEVICES += phicomm,k2t
+endef
+TARGET_DEVICES += phicomm-k2t