aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorTobias Schramm <tobleminer@gmail.com>2019-12-03 22:39:01 +0100
committerDavid Bauer <mail@david-bauer.net>2020-01-12 14:12:50 +0100
commit7d97fdf5ef71c1c171f8c01dee2c0c1695741bdf (patch)
tree01469118fd2c0263cc8a2a6cb5aa8ac449def135 /target/linux/ath79/image
parentd29929be073ad74585043dc4f74e8581dd9e657c (diff)
downloadupstream-7d97fdf5ef71c1c171f8c01dee2c0c1695741bdf.tar.gz
upstream-7d97fdf5ef71c1c171f8c01dee2c0c1695741bdf.tar.bz2
upstream-7d97fdf5ef71c1c171f8c01dee2c0c1695741bdf.zip
ath79: add support for Ubiquiti SW devices
SW devices are Ubiquit ToughSwitch and EdgeSwitch series devices. Hardware-wise they are very similar to the XM device series. Signed-off-by: Tobias Schramm <tobleminer@gmail.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 05847cc3a2..f6546f369e 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -47,6 +47,18 @@ define Device/ubnt-bz
UBNT_VERSION := 6.0.0
endef
+define Device/ubnt-sw
+ $(Device/ubnt)
+ SOC := ar7242
+ DEVICE_PACKAGES += kmod-usb-ohci
+ IMAGE_SIZE := 7552k
+ UBNT_BOARD := SW
+ UBNT_CHIP := ar7240
+ UBNT_TYPE := SW
+ UBNT_VERSION := 1.4.1
+ KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma | uImage lzma
+endef
+
define Device/ubnt-wa
$(Device/ubnt)
SOC := ar9342