aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorJeff Kletsky <git-commits@allycomm.com>2019-10-23 09:56:47 -0700
committerJohn Crispin <john@phrozen.org>2019-10-24 23:06:26 +0200
commit18848312c5d2605be0c6ef8905daf08e2ec58eae (patch)
tree248d08529cef2ec82702d773d176697dea57c2cf /target/linux/ath79/image
parent1f748df085590daf4d220b50123082bb0d9b465c (diff)
downloadupstream-18848312c5d2605be0c6ef8905daf08e2ec58eae.tar.gz
upstream-18848312c5d2605be0c6ef8905daf08e2ec58eae.tar.bz2
upstream-18848312c5d2605be0c6ef8905daf08e2ec58eae.zip
ath79: Refactor GL.iNet GL-AR300M-series generic.mk
Rework DEVICE_VENDOR, DEVICE_MODEL, and DEVICE_VARIANT for the GL-AR300M series on the ath79-generic target. Changes GL-AR300M-Lite to the current form with DEVICE_VARIANT := Lite (board name is unchanged) Signed-off-by: Jeff Kletsky <git-commits@allycomm.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index e82e125166..3373956e45 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -549,6 +549,7 @@ TARGET_DEVICES += glinet_gl-ar150
define Device/glinet_gl-ar300m-common-nor
ATH_SOC := qca9531
+ DEVICE_VENDOR := GL.iNet
DEVICE_PACKAGES := kmod-usb2
IMAGE_SIZE := 16000k
SUPPORTED_DEVICES += gl-ar300m
@@ -556,14 +557,13 @@ endef
define Device/glinet_gl-ar300m-lite
$(Device/glinet_gl-ar300m-common-nor)
- DEVICE_VENDOR := GL.iNet
- DEVICE_MODEL := GL-AR300M-Lite
+ DEVICE_MODEL := GL-AR300M
+ DEVICE_VARIANT := Lite
endef
TARGET_DEVICES += glinet_gl-ar300m-lite
define Device/glinet_gl-ar300m-nor
$(Device/glinet_gl-ar300m-common-nor)
- DEVICE_VENDOR := GL.iNet
DEVICE_MODEL := GL-AR300M
endef
TARGET_DEVICES += glinet_gl-ar300m-nor