aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-05-08 07:22:38 +0200
committerMathias Kresin <dev@kresin.me>2018-05-17 07:40:19 +0200
commit0ff5785c5d5e57d99acb8da06d2c08903448b663 (patch)
tree4541e482fb5751cbedcaf1e94fd9dae380432cdc /target/linux/ath79/image
parent8f7e28a7835521e8e0e6f9ff44005c3374e39bf0 (diff)
downloadupstream-0ff5785c5d5e57d99acb8da06d2c08903448b663.tar.gz
upstream-0ff5785c5d5e57d99acb8da06d2c08903448b663.tar.bz2
upstream-0ff5785c5d5e57d99acb8da06d2c08903448b663.zip
ath79: fix dts files
Add the SoC compatible to the individual dts files. Rename the dts files to match the common pattern. Remove dts files wich aren't used and no image in ar71xx exists. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk16
-rw-r--r--target/linux/ath79/image/generic.mk14
2 files changed, 15 insertions, 15 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 17c89fcb1c..b614152263 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -81,35 +81,35 @@ define Device/ubnt-airrouter
endef
#TARGET_DEVICES += ubnt-airrouter
-define Device/ubnt-bullet-m
+define Device/ubnt_bullet-m
$(Device/ubnt-xm)
DEVICE_TITLE := Ubiquiti Bullet-M
BOARDNAME := UBNT-BM
endef
-TARGET_DEVICES += ubnt-bullet-m
+TARGET_DEVICES += ubnt_bullet-m
-define Device/ubnt-rocket-m
+define Device/ubnt_rocket-m
$(Device/ubnt-xm)
DEVICE_TITLE := Ubiquiti Rocket-M
BOARDNAME := UBNT-RM
endef
-TARGET_DEVICES += ubnt-rocket-m
+TARGET_DEVICES += ubnt_rocket-m
-define Device/ubnt-nano-m
+define Device/ubnt_nano-m
$(Device/ubnt-xm)
DEVICE_TITLE := Ubiquiti Nano-M
BOARDNAME := UBNT-NM
endef
-TARGET_DEVICES += ubnt-nano-m
+TARGET_DEVICES += ubnt_nano-m
-define Device/ubnt-unifi
+define Device/ubnt_unifi
$(Device/ubnt-bz)
ATH_SOC := ar7241
DEVICE_TITLE := Ubiquiti UniFi
BOARDNAME := UBNT-UF
DEVICE_PROFILE += UBNTUNIFI
endef
-TARGET_DEVICES += ubnt-unifi
+TARGET_DEVICES += ubnt_unifi
define Device/ubnt-unifiac
DEVICE_PACKAGES := kmod-usb-core kmod-usb2
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index dab98b7225..d6983605cc 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -21,30 +21,30 @@ define Build/netgear-uImage
$(call Build/uImage,$(1) -M $(NETGEAR_KERNEL_MAGIC))
endef
-define Device/ew_dorin
+define Device/embeddedwireless_dorin
ATH_SOC := ar9331
DEVICE_TITLE := Embedded Wireless Dorin
DEVICE_PACKAGES := kmod-usb-chipidea2
endef
-TARGET_DEVICES += ew_dorin
+TARGET_DEVICES += embeddedwireless_dorin
-define Device/gl_ar150
+define Device/glinet_ar150
ATH_SOC := ar9330
DEVICE_TITLE := GL.iNet GL-AR150
DEVICE_PACKAGES := kmod-usb-chipidea2
IMAGE_SIZE := 16000k
endef
-TARGET_DEVICES += gl_ar150
+TARGET_DEVICES += glinet_ar150
-define Device/om5p_ac
+define Device/openmesh_om5p-ac-v2
ATH_SOC := qca9558
- DEVICE_TITLE := OpenMesh OM5P-AC
+ DEVICE_TITLE := OpenMesh OM5P-AC v2
DEVICE_PROFILE := OM5P-AC
DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x om-watchdog
endef
-TARGET_DEVICES += om5p_ac
+TARGET_DEVICES += openmesh_om5p-ac-v2
define Device/netgear_wndr3700
ATH_SOC:=ar7100