aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2018-09-04 23:27:02 +0200
committerJohn Crispin <john@phrozen.org>2018-09-10 09:07:41 +0200
commit745dee11ac787e9ffb4c15799961fa02d6462c8b (patch)
treed763015dd03d96cef2403434bc7a5cc8d54525a8 /target/linux/ath79/image
parentcd9c2492c18d1c2abd200e5911ad546d7c77a617 (diff)
downloadupstream-745dee11ac787e9ffb4c15799961fa02d6462c8b.tar.gz
upstream-745dee11ac787e9ffb4c15799961fa02d6462c8b.tar.bz2
upstream-745dee11ac787e9ffb4c15799961fa02d6462c8b.zip
ath79: add support for WD My Net Wi-Fi Range Extender
This patch ports over support for the device from ar71xx. SOC: AR7370 (Wasp - AR9344 rev2 0001974c) RAM: Winbond W9725G6KB-25 32MiB FLASH: Winbond 25Q64FVSIG 8MiB WLAN: AR9380 Dual-Band 802.11abgn 3x3:3 INPUT: WPS, RESET button (hardware on/off toggle button) LED: Power, LAN, WiFi, 3 RSSI-Leds (low, medium, high) Serial: Header Next to the winbond flash chip (labeld JP1) Pinout is GND - NC - RX - TX - 3V3 (JP1) The Serial setting is 115200-8-N-1. - Installation via uboot's upgrade command 0. attach serial cable 1. interrupt uboot and enter "upgrade code.bin" into the u-boot prompt ar7240> upgrade code.bin 2. rename openwrt...sysupgrade.bin to code.bin on PC 3. run a tftp-client on the PC (shell)$ tftp 192.168.1.230 binary put code.bin 4. wait for the device to finish [...] Copy buff to Flash from 0x9f040000 length 0x79f000 Copy to Flash... write addr: 9f040000 done 5. enter "go" in the u-boot prompt ar7240> go - TFTP ramdisk image boot from the uboot prompt (tftp server defaults to serverip 192.168.1.254) => tftpboot 81000000 initramfs.bin => bootm Tested and working: - LEDs - Buttons - Ethernet - Wi-Fi - OpenWRT sysupgrade For flashing and debricking information see: <https://openwrt.org/toh/wd/rext> Users coming from ar71xx can use sysupgrade too. But I highly advise to no save the old configuration and start from a clean state. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index e35a3568a8..60dc512f06 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1,5 +1,22 @@
include ./common-netgear.mk
+DEVICE_VARS += ADDPATTERN_ID ADDPATTERN_VERSION
+
+define Build/cybertan-trx
+ @echo -n '' > $@-empty.bin
+ -$(STAGING_DIR_HOST)/bin/trx -o $@.new \
+ -f $(IMAGE_KERNEL) -F $@-empty.bin \
+ -x 32 -a 0x10000 -x -32 -f $@
+ -mv "$@.new" "$@"
+ -rm $@-empty.bin
+endef
+
+define Build/addpattern
+ -$(STAGING_DIR_HOST)/bin/addpattern -B $(ADDPATTERN_ID) \
+ -v v$(ADDPATTERN_VERSION) -i $@ -o $@.new
+ -mv "$@.new" "$@"
+endef
+
define Device/avm_fritz300e
ATH_SOC := ar7242
DEVICE_TITLE := AVM FRITZ!WLAN Repeater 300E
@@ -232,3 +249,16 @@ define Device/phicomm_k2t
DEVICE_PACKAGES := kmod-leds-reset kmod-ath10k ath10k-firmware-qca9888
endef
TARGET_DEVICES += phicomm_k2t
+
+define Device/wd_mynet-wifi-rangeextender
+ ATH_SOC := ar9344
+ DEVICE_TITLE := Western Digital My Net Wi-Fi Range Extender
+ DEVICE_PACKAGES := rssileds nvram -swconfig
+ IMAGE_SIZE := 7808k
+ ADDPATTERN_ID := mynet-rext
+ ADDPATTERN_VERSION := 1.00.01
+ IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | cybertan-trx | \
+ addpattern | append-metadata
+ SUPPORTED_DEVICES += mynet-rext
+endef
+TARGET_DEVICES += wd_mynet-wifi-rangeextender