aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2018-10-02 22:28:45 +0900
committerMathias Kresin <dev@kresin.me>2018-10-07 15:44:19 +0200
commit6d1abbcab482556ad13cc7285680b97d4a28a465 (patch)
tree29e6a577c6cb51bbf83c0b7b84466947df2c11b5 /target/linux/ath79/image
parentd745eac636f017d8a6ac2091746c985fcd8d2851 (diff)
downloadupstream-6d1abbcab482556ad13cc7285680b97d4a28a465.tar.gz
upstream-6d1abbcab482556ad13cc7285680b97d4a28a465.tar.bz2
upstream-6d1abbcab482556ad13cc7285680b97d4a28a465.zip
ath79: add support for Buffalo WZR-HP-G302H A1A0
Buffalo WZR-HP-G302H is a 2T2R 2.4 GHz 11n router, based on Atheros AR7242. It is Japanese market model of WZR-HP-G300NH2, but there are some diffrences. This commit is based on WZR-HP-G300NH2 in ar71xx. And, G302H has several hardware versions and hardware is different dependent on the versions. This commit adds support for "A1A0" version. Specification: - Atheros AR7242 - 64 MB of RAM (DDR2) - 32 MB of Flash - 2x 16 MB SPI-NOR flash - 2.4 GHz 2T2R wifi - Atheros AR9283 - 5x 10/100/1000 Mbps Ethernet - Atheros AR8316 - 7x LEDs, 5x keys - LED: 1x gpio-leds, 6x ath9k-leds - key: 3x buttons, 2x slide switches - UART header on PCB - Vcc, GND, TX, RX from ethernet port side - 115200n8 Flash instruction using factory image: 1. Boot WZR-HP-G302H normaly and connect the computer to its LAN port 2. Access to "http://192.168.11.1/" and move to firmware update page ("ファーム更新") 3. Select the OpenWrt factory image and click update ("更新実行") button to perform firmware update 4. Wait ~200 seconds to complete flashing Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 80ec2311b4..75e93998a9 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -95,6 +95,19 @@ define Device/buffalo_wzr-hp-ag300h
endef
TARGET_DEVICES += buffalo_wzr-hp-ag300h
+define Device/buffalo_wzr-hp-g302h-a1a0
+ ATH_SOC := ar7242
+ DEVICE_TITLE := Buffalo WZR-HP-G302H A1A0
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+ IMAGE_SIZE := 32128k
+ IMAGES += factory.bin tftp.bin
+ IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.bin := $$(IMAGE/default) | buffalo-enc WZR-HP-G302H 1.99 | buffalo-tag WZR-HP-G302H 4
+ IMAGE/tftp.bin := $$(IMAGE/default) | buffalo-tftp-header
+ SUPPORTED_DEVICES += wzr-hp-g300nh2
+endef
+TARGET_DEVICES += buffalo_wzr-hp-g302h-a1a0
+
define Device/buffalo_wzr-hp-g450h
ATH_SOC := ar7242
DEVICE_TITLE := Buffalo WZR-HP-G450H/WZR-450HP