aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2018-11-30 19:04:23 +0900
committerMathias Kresin <dev@kresin.me>2018-12-06 20:26:57 +0100
commit3358cae5238d66c73b0328b007a1cbb073bc8275 (patch)
tree65011b51cf01491bfed2d6f61c5187eafa22bb23 /target/linux/ath79/image
parent9dd7147f6bce44a49fef594f55b120253baf5556 (diff)
downloadupstream-3358cae5238d66c73b0328b007a1cbb073bc8275.tar.gz
upstream-3358cae5238d66c73b0328b007a1cbb073bc8275.tar.bz2
upstream-3358cae5238d66c73b0328b007a1cbb073bc8275.zip
ath79: add support for I-O DATA WN-AG300DGR
I-O DATA WN-AG300DGR is a 2T2R 2.4/5 GHz 11n router, based on Atheros AR1022. WN-AG300DGR does not have an LED to indicates power or system status, I set "router" LED as OpenWrt status LED. There is no eeprom data for 5 GHz wlan in "art" partition. Specification: - Atheros AR1022 - 64 MB of RAM (DDR2) - 8 MB of Flash (SPI-NOR) - 2T2R 2.4/5GHz wifi - 2.4 GHz: SoC internal - 5 GHz: Atheros AR93x2 - 5x 10/100/1000 Mbps Ethernet - 6x LEDs, 6x keys (4x buttons, 1x slide switch) - 1x USB 2.0 Type-A - UART through-hole on PCB - Vcc, GND, TX, RX from ethernet port side - 115200n8 Flash instruction using factory image: 1. Connect the computer to the LAN port on WN-AG300DGR 2. Connect power cable to WN-AG300DGR and turn it 3. Access to "http://192.168.0.1/" and open firmware update page ("ファームウェア") 4. Select the OpenWrt factory image and click update ("更新") button 5. Wait ~150 seconds to complete flashing Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 74d185ea63..df91c91826 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -222,6 +222,18 @@ define Device/iodata_wn-ac1600dgr2
endef
TARGET_DEVICES += iodata_wn-ac1600dgr2
+define Device/iodata_wn-ag300dgr
+ ATH_SOC := ar1022
+ DEVICE_TITLE := I-O DATA WN-AG300DGR
+ IMAGE_SIZE := 15424k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | \
+ senao-header -r 0x30a -p 0x47 -t 2
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+endef
+TARGET_DEVICES += iodata_wn-ag300dgr
+
define Device/ocedo_koala
ATH_SOC := qca9558
DEVICE_TITLE := OCEDO Koala