aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2018-09-11 20:13:17 +0900
committerMathias Kresin <dev@kresin.me>2018-09-26 20:35:07 +0200
commit1df1ea4d7e8b6ae3351780ed58800ccd9edd4c27 (patch)
tree0ec309cb5d905e9de750ff4f2259de68bb3f8ba4 /target/linux/ath79/image
parentb6e6785c88abe5183a6c8ebcd20e1175933883d5 (diff)
downloadupstream-1df1ea4d7e8b6ae3351780ed58800ccd9edd4c27.tar.gz
upstream-1df1ea4d7e8b6ae3351780ed58800ccd9edd4c27.tar.bz2
upstream-1df1ea4d7e8b6ae3351780ed58800ccd9edd4c27.zip
ath79: fix support for Buffalo WZR-HP-G450H and split to dts/dtsi
There are many parts that are incorrect or missing in the current code for Buffalo WZR-HP-G450H in ath79, so its support is broken. I fixed that issues and split to dts/dtsi files to add support for Buffalo BHR-4GRV. And WZR-450HP has the same hardware as WZR-HP-G450H, so I change the device name to "WZR-HP-G450H/WZR-450HP". Specification: - Atheros AR7242 - 64 MB of RAM - 32 MB of Flash - 2x 16 MB SPI-NOR flash - 3T3R 2.4 GHz wifi - SoC internal - 5x 10/100/1000 Mbps Ethernet - 6x LEDs, 5x keys - 1x USB 2.0 Type-A - UART header on PCB - JP1: Vcc, GND, TX, RX from reset button side Flash instruction using factory image: 1. Boot the WZR-HP-G450H (or WZR-450HP) normaly and connect the computer to its LAN port 2. Access to "http://192.168.11.1/cgi-bin/cgi?req=frm&frm=py-db/firmup.html" with user "bufpy" and password "otdpopy" 3. Select the OpenWrt factory image and click "OK" button to perform firmware update 4. Wait ~200 seconds to complete flashing Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 2727fb6ca1..91325cf4d4 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -84,9 +84,13 @@ TARGET_DEVICES += buffalo_wzr-hp-ag300h
define Device/buffalo_wzr-hp-g450h
ATH_SOC := ar7242
- DEVICE_TITLE := Buffalo WZR-HP-G450H
+ DEVICE_TITLE := Buffalo WZR-HP-G450H/WZR-450HP
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
IMAGE_SIZE := 32256k
+ IMAGES += factory.bin tftp.bin
+ IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.bin := $$(IMAGE/default) | buffalo-enc WZR-HP-G450H 1.99 | buffalo-tag WZR-HP-G450H
+ IMAGE/tftp.bin := $$(IMAGE/default) | buffalo-tftp-header
SUPPORTED_DEVICES += wzr-hp-g450h
endef
TARGET_DEVICES += buffalo_wzr-hp-g450h