aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorGuan-Hong Lin <GH.Lin@senao.com>2018-12-18 16:35:30 +0800
committerMathias Kresin <dev@kresin.me>2018-12-31 16:25:09 +0100
commit9ebb44aef4db8f423f7bf1fd2436906b2eafb570 (patch)
treefa0cb2c337b5dcebbc60769e16770a7a7e6e4a46 /target/linux/ath79/image
parent48745221a8b4cdd18811a071387915e3ad1587ee (diff)
downloadupstream-9ebb44aef4db8f423f7bf1fd2436906b2eafb570.tar.gz
upstream-9ebb44aef4db8f423f7bf1fd2436906b2eafb570.tar.bz2
upstream-9ebb44aef4db8f423f7bf1fd2436906b2eafb570.zip
ath79: add support for EnGenius EWS511AP
EnGenius EWS511AP is a wireless managed wall AP with PoE support, based on Qualcomm/Atheros QCA9531(Honeybee) + QCA9887. Short specification: - 128MB of RAM - 16 MB of SPI FLASH - 2T2R 2.4 GHz (QCA9531), 802.11b/g/n - 1T1R 5 GHz (QCA9887), 802.11ac/n/a - 2x 10/100 Mbps Ethernet (one port with PoE support) - 1x Power LED, 2x LAN LEDs, 1x WLAN 2.4G LED, 1x WLAN 5G LED - 1x RESET button - built-in watchdog chipset Flash instruction: From EnGenius firmware to OpenWrt firmware: Original firmware is based on QSDK. Use sysupgrade firmware directly in vendor GUI. Reset to factory default is necessary. From OpenWrt firmware to EnGenius firmware: 1. Setup a TFTP server on your computer and configure static IP to 192.168.99.8 Put the OpenWrt firmware in the root directory on your computer. 2. Power up EWS511AP. Press 4 and then press any key to enter u-boot. 3. Download OpenWrt firmware (ath)> tftpboot 0x80060000 ${dir}"openwrt-ath79-generic-engenius_ews511ap-squashfs-sysupgrade.bin" 4. Flash the firmware (ath)> erase 0x9f060000 +f50000 (ath)> cp.b $fileaddr 0x9f060000 $filesize 5. Reboot (ath)> reset Signed-off-by: Guan-Hong Lin <GH.Lin@senao.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 774695b8b4..aedd67d699 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -250,6 +250,14 @@ define Device/embeddedwireless_dorin
endef
TARGET_DEVICES += embeddedwireless_dorin
+define Device/engenius_ews511ap
+ ATH_SOC := qca9531
+ DEVICE_TITLE := EnGenius EWS511AP
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9887-ct
+ IMAGE_SIZE := 16000k
+endef
+TARGET_DEVICES += engenius_ews511ap
+
define Device/etactica_eg200
ATH_SOC := ar9331
DEVICE_TITLE := eTactica EG200