aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-01-01 19:17:22 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-01-05 21:55:22 +0100
commit8d68be8057d6c689025cc236d20b96b77a6ccf30 (patch)
treeddf3f9b2995c550628a6a12fe5fa6d03eb9d88f6 /target/linux/ath79/image
parent6ba58b7b020c4b793e6fb7a43c8adef070579d8d (diff)
downloadupstream-8d68be8057d6c689025cc236d20b96b77a6ccf30.tar.gz
upstream-8d68be8057d6c689025cc236d20b96b77a6ccf30.tar.bz2
upstream-8d68be8057d6c689025cc236d20b96b77a6ccf30.zip
ath79: add support for devolo WiFi pro 1750i
Hardware -------- CPU: Qualcomm Atheros QCA9558 RAM: 128M DDR2 FLASH: 16MiB ETH: 1x Atheros AR8035 (PoE in) WiFi2: QCA9558 3T3R WiFi5: QCA9880 3T3R BTN: 1x Reset LED: 1x LED blue 1x LED red BEEP: 1x GPIO attached piezo beeper UART: 3.3V GND TX RX (115200-N-8) (3.3V is square pad) Header is located next to reset-button Installation ------------ Make sure you set a password for the root user as prompted on first setup! 1. Upload OpenWRT sysupgrade image via SSH to the device. Use /tmp as the destination folder on the device. User is root, password the one set in the web interface. 2. Install OpenWRT with > sysupgrade -n -F /tmp/<openwrt-image-name> Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 858c1662cc..438a842182 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -178,6 +178,14 @@ define Device/devolo_dvl1750c
endef
TARGET_DEVICES += devolo_dvl1750c
+define Device/devolo_dvl1750i
+ ATH_SOC := qca9558
+ DEVICE_TITLE := devolo WiFi pro 1750i
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += devolo_dvl1750i
+
define Device/dlink_dir-825-b1
ATH_SOC := ar7161
DEVICE_TITLE := D-LINK DIR-825 B1