aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny.mk
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-10 22:58:27 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-21 20:02:55 +0100
commit3f14f034fb5e191f4a537998379d8e922ec31e8a (patch)
tree2daa222bf570dcd278377f8fe4c8969a92d4ead0 /target/linux/ath79/image/tiny.mk
parent1444e31a7bf54b796f8ef88e77fee255b959c6bb (diff)
downloadupstream-3f14f034fb5e191f4a537998379d8e922ec31e8a.tar.gz
upstream-3f14f034fb5e191f4a537998379d8e922ec31e8a.tar.bz2
upstream-3f14f034fb5e191f4a537998379d8e922ec31e8a.zip
treewide: omit IMAGE_SIZE argument from check-size
Now that check-size uses IMAGE_SIZE by default, we can skip the argument from image recipes to reduce redundancy. Signed-off-by: Sungbo Eo <mans0n@gorani.run> [do not touch ar71xx] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/tiny.mk')
-rw-r--r--target/linux/ath79/image/tiny.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ath79/image/tiny.mk b/target/linux/ath79/image/tiny.mk
index 54b20b6089..41f1eb4305 100644
--- a/target/linux/ath79/image/tiny.mk
+++ b/target/linux/ath79/image/tiny.mk
@@ -7,7 +7,7 @@ define Device/buffalo_whr-g301n
IMAGE_SIZE := 3712k
IMAGES += factory.bin tftp.bin
IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
- pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ pad-rootfs | check-size
IMAGE/factory.bin := $$(IMAGE/default) | buffalo-enc WHR-G301N 1.99 | \
buffalo-tag WHR-G301N 3
IMAGE/tftp.bin := $$(IMAGE/default) | buffalo-tftp-header
@@ -25,7 +25,7 @@ define Device/dlink_dir-615-e4
IMAGES += factory.bin
IMAGE/default := append-kernel | append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
IMAGE/factory.bin := $$(IMAGE/default) | \
check-size $$$$(FACTORY_IMAGE_SIZE) | pad-to $$$$(FACTORY_IMAGE_SIZE) | \
append-string "AP99-AR7240-RT-091105-05"