aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2019-06-16 21:34:46 +0200
committerDaniel Golle <daniel@makrotopia.org>2019-07-04 15:50:17 +0200
commit8c3dbaf8b49233e275b2dce4e30dc0a2bf8c86c5 (patch)
treeb58ad085eae892fa35cb6e7a8f0b09373b5c4d3e /target/linux/ath79/image/tiny.mk
parentcb689f2723b40c96426ac69f1478530ff1d48368 (diff)
downloadupstream-8c3dbaf8b49233e275b2dce4e30dc0a2bf8c86c5.tar.gz
upstream-8c3dbaf8b49233e275b2dce4e30dc0a2bf8c86c5.tar.bz2
upstream-8c3dbaf8b49233e275b2dce4e30dc0a2bf8c86c5.zip
ath79: split DEVICE_TITLE in multiple variables
This allows the definition of DEVICE_VENDOR, DEVICE_MODEL and DEVICE_VARIANT. All three are merged together to look the same as the current DEVICE_TITLE. Also, if DEVICE_TITLE is set it's directly used as a *fallback* for devices which weren't upgraded yet. This is based on the work of @sudhanshu16. The motivation is to create JSON files based on provided metadata, needing clear differentiation between vendor, model and revision. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'target/linux/ath79/image/tiny.mk')
-rw-r--r--target/linux/ath79/image/tiny.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/ath79/image/tiny.mk b/target/linux/ath79/image/tiny.mk
index bf7a5e140b..fb93cb60f5 100644
--- a/target/linux/ath79/image/tiny.mk
+++ b/target/linux/ath79/image/tiny.mk
@@ -2,7 +2,8 @@ include ./common-buffalo.mk
define Device/buffalo_whr-g301n
ATH_SOC := ar7240
- DEVICE_TITLE := Buffalo WHR-G301N
+ DEVICE_VENDOR := Buffalo
+ DEVICE_MODEL := WHR-G301N
IMAGE_SIZE := 3712k
IMAGES += factory.bin tftp.bin
IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
@@ -14,7 +15,8 @@ TARGET_DEVICES += buffalo_whr-g301n
define Device/pqi_air-pen
ATH_SOC := ar9330
- DEVICE_TITLE := PQI Air-Pen
+ DEVICE_VENDOR := PQI
+ DEVICE_MODEL := Air-Pen
DEVICE_PACKAGES := kmod-usb-core kmod-usb2
IMAGE_SIZE := 7680k
SUPPORTED_DEVICES += pqi-air-pen