aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny-tp-link.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-09 15:00:55 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-27 17:15:07 +0100
commitbdbda30384980ed545391ddf23308ca4bde34770 (patch)
treeea6c34ee6e9230c1ece28543ae90ca01ee96624f /target/linux/ath79/image/tiny-tp-link.mk
parent2e6bfab8c59f4c76ae3f3ccd1d3e09844e889ecc (diff)
downloadupstream-bdbda30384980ed545391ddf23308ca4bde34770.tar.gz
upstream-bdbda30384980ed545391ddf23308ca4bde34770.tar.bz2
upstream-bdbda30384980ed545391ddf23308ca4bde34770.zip
ath79: add support for TP-Link TL-WA860RE v1
This ports support for the TL-WA860RE v1 range extender from ar71xx to ath79. Specifications: Board: AP123 / AR9341 rev. 3 Flash/RAM: 4/32 MiB CPU: 535 MHz WiFi: 2.4 GHz b/g/n Ethernet: 1 port (100M) Two external antennas Flashing instructions: Upload the factory image via the vendor firmware upgrade option. Recovery: Note that this device does not provide TFTP via ethernet like many other TP-Link devices do. You will have to open the case if you require recovery beyond failsafe. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Tested-by: Sebastian Knapp <sebastian4842@outlook.com> (cherry picked from commit 385f4868bc58b04e465db2fbcfce848a75009a74)
Diffstat (limited to 'target/linux/ath79/image/tiny-tp-link.mk')
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index 7d8f124e87..6a3734d814 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -61,6 +61,15 @@ define Device/tplink_tl-wa850re-v1
endef
TARGET_DEVICES += tplink_tl-wa850re-v1
+define Device/tplink_tl-wa860re-v1
+ $(Device/tplink-4mlzma)
+ ATH_SOC := ar9341
+ DEVICE_TITLE := TP-Link TL-WA860RE v1
+ TPLINK_HWID := 0x08600001
+ SUPPORTED_DEVICES += tl-wa860re
+endef
+TARGET_DEVICES += tplink_tl-wa860re-v1
+
define Device/tplink_tl-wa901nd-v2
$(Device/tplink-4m)
ATH_SOC := ar9132