aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny-tp-link.mk
diff options
context:
space:
mode:
authorJun Su <howard0su@gmail.com>2020-03-03 17:33:40 +0800
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-14 13:27:41 +0100
commit7ae345ecb74ef6b7a6d9807292cf5586d4536797 (patch)
tree7497467e6ba6ea5ebd8a4360a1f8d3f350f23c12 /target/linux/ath79/image/tiny-tp-link.mk
parent76c1c1daead558f970c614f73dde0698da42743b (diff)
downloadupstream-7ae345ecb74ef6b7a6d9807292cf5586d4536797.tar.gz
upstream-7ae345ecb74ef6b7a6d9807292cf5586d4536797.tar.bz2
upstream-7ae345ecb74ef6b7a6d9807292cf5586d4536797.zip
ath79: add support for TP-Link TL-WR740N v5
This adds support for the TP-Link TL-WR740N v5, a clone of the v4 only with a different TPLINK_HWID. It was already supported in ar71xx as well. Specifications: SOC: Atheros AR9331 CPU: 400MHz Flash: 4 MiB RAM: 32 MiB WLAN: Atheros AR9330 bgn Ethernet: 5 ports (100M) Flashing instructions: - Flash factory image from OEM WebUI: openwrt-ath79-tiny-tplink_tl-wr740n-v5-squashfs-factory.bin - Sysupgrade from ar71xx image: openwrt-ath79-tiny-tplink_tl-wr740n-v5-squashfs-sysupgrade.bin Signed-off-by: Jun Su <howard0su@gmail.com> [commit title/message facelift, backport for 19.07] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> (cherry picked from commit b9f4f1f97aeeec65a872c4c5b1a0528a69d16d7b)
Diffstat (limited to 'target/linux/ath79/image/tiny-tp-link.mk')
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index 817f5d8ed6..84b0d320b1 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -93,6 +93,14 @@ define Device/tplink_tl-wr740n-v4
endef
TARGET_DEVICES += tplink_tl-wr740n-v4
+define Device/tplink_tl-wr740n-v5
+ $(Device/tplink-4mlzma)
+ ATH_SOC := ar9331
+ DEVICE_TITLE := TP-Link TL-WR740N v5
+ TPLINK_HWID := 0x07400005
+endef
+TARGET_DEVICES += tplink_tl-wr740n-v5
+
define Device/tplink_tl-wr741-v1
$(Device/tplink-4m)
ATH_SOC := ar7240