aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny-tp-link.mk
diff options
context:
space:
mode:
authorAntonio Silverio <menion@gmail.com>2018-10-17 09:18:45 +0200
committerMathias Kresin <dev@kresin.me>2018-12-31 13:28:31 +0100
commit9601d94138de66e4fc9f55a08dfb348cdfcc3181 (patch)
treec3431d8c62e94465203f22f7d21052e5feb446a9 /target/linux/ath79/image/tiny-tp-link.mk
parent98f826fdc0a982bea9eee8f397fdf0d2ef018cab (diff)
downloadupstream-9601d94138de66e4fc9f55a08dfb348cdfcc3181.tar.gz
upstream-9601d94138de66e4fc9f55a08dfb348cdfcc3181.tar.bz2
upstream-9601d94138de66e4fc9f55a08dfb348cdfcc3181.zip
ath79: add support for TP-Link TL-WR841N/ND v8
CPU: Atheros AR9341 535MHz RAM: 32MB FLASH: 4MiB PORTS: 4 Port 100/10 Switch, 1 Port 100/10 Wan WiFi: Atheros AR9341 2x2:2 bgn LED: Power (static on), LAN (controlled by Switch), WAN, SYS, WiFi, RFKill BTN: WPS, WiFi, Reset Installation: Upload the factory image via the vendor-GUI. Signed-off-by: Antonio Silverio <menion@gmail.com> [resolve merge conflicts, squash commits, fix commit title, remove default default off led properties, mark sysupgrade image compatible with the ar71xx version of the board, drop blank lines from dts] Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ath79/image/tiny-tp-link.mk')
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index e0c7e283c8..a7a6587889 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -136,6 +136,15 @@ define Device/tplink_tl-wr841-v7
endef
TARGET_DEVICES += tplink_tl-wr841-v7
+define Device/tplink_tl-wr841-v8
+ $(Device/tplink-4mlzma)
+ ATH_SOC := ar9341
+ DEVICE_TITLE := TP-LINK TL-WR841N/ND v8
+ TPLINK_HWID := 0x08410008
+ SUPPORTED_DEVICES += tl-wr841n-v8
+endef
+TARGET_DEVICES += tplink_tl-wr841-v8
+
define Device/tplink_tl-wr841-v9
$(Device/tplink-4mlzma)
ATH_SOC := qca9533