aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/mikrotik.mk
diff options
context:
space:
mode:
authorDavid Musil <0x444d@protonmail.com>2022-04-16 12:01:31 +0000
committerPetr Štetiar <ynezz@true.cz>2022-04-18 07:24:09 +0200
commite20de224427008e0f26161f924bc347d974fd15a (patch)
tree95e531d29abceae8b6446726237c7a0f96a17d0c /target/linux/ath79/image/mikrotik.mk
parent7dc52a78ae2c2f748a0c0c4adcb13979260b3498 (diff)
downloadupstream-e20de224427008e0f26161f924bc347d974fd15a.tar.gz
upstream-e20de224427008e0f26161f924bc347d974fd15a.tar.bz2
upstream-e20de224427008e0f26161f924bc347d974fd15a.zip
ath79: add support for MikroTik RouterBOARD wAP-2nD (wAP)
The MikroTik RouterBOARD wAP-2nd (sold as wAP) is a small 2.4 GHz 802.11b/g/n PoE-capable AP. Specifications: - SoC: Qualcomm Atheros QCA9533 - Flash: 16 MB (SPI) - RAM: 64 MB - Ethernet: 1x 10/100 Mbps (PoE in) - WiFi: AR9531 2T2R 2.4 GHz (SoC) - 3x green LEDs (1x lan, 1x wlan, 1x user) See https://mikrotik.com/product/RBwAP2nD for more info. Flashing: TFTP boot initramfs image and then perform sysupgrade. Follow common MikroTik procedure as in https://openwrt.org/toh/mikrotik/common. Note: following 781d4bfb397cdd12ee0151eb66c577f470e3377d The network setup avoids using the integrated switch and connects the single Ethernet port directly. This way, link speed (10/100 Mbps) is properly reported by eth0. Signed-off-by: David Musil <0x444d@protonmail.com>
Diffstat (limited to 'target/linux/ath79/image/mikrotik.mk')
-rw-r--r--target/linux/ath79/image/mikrotik.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/mikrotik.mk b/target/linux/ath79/image/mikrotik.mk
index 13aec3949a..30c1761134 100644
--- a/target/linux/ath79/image/mikrotik.mk
+++ b/target/linux/ath79/image/mikrotik.mk
@@ -101,3 +101,11 @@ define Device/mikrotik_routerboard-wapr-2nd
IMAGE_SIZE := 16256k
endef
TARGET_DEVICES += mikrotik_routerboard-wapr-2nd
+
+define Device/mikrotik_routerboard-wap-2nd
+ $(Device/mikrotik_nor)
+ SOC := qca9533
+ DEVICE_MODEL := RouterBOARD wAP-2nD (wAP)
+ IMAGE_SIZE := 16256k
+endef
+TARGET_DEVICES += mikrotik_routerboard-wap-2nd