aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/mikrotik.mk
diff options
context:
space:
mode:
authorThibaut VARÈNE <hacks@slashdirt.org>2022-02-28 11:34:43 +0100
committerPetr Štetiar <ynezz@true.cz>2022-03-08 18:33:42 +0100
commiteb38af788180d624e5b37aa5db1fe3766b138dc8 (patch)
treeefd187f14c73327b4c5cfe95f235bf6f5725fc39 /target/linux/ath79/image/mikrotik.mk
parent549f8694c308761c25690a519de724ea3ad2bd76 (diff)
downloadupstream-eb38af788180d624e5b37aa5db1fe3766b138dc8.tar.gz
upstream-eb38af788180d624e5b37aa5db1fe3766b138dc8.tar.bz2
upstream-eb38af788180d624e5b37aa5db1fe3766b138dc8.zip
ath79: add support for MikroTik RouterBOARD mAP lite
The MikroTik RouterBOARD mAPL-2nd (sold as mAP Lite) is a small 2.4 GHz 802.11b/g/n PoE-capable AP. See https://mikrotik.com/product/RBmAPL-2nD for more info. Specifications: - SoC: Qualcomm Atheros QCA9533 - RAM: 64 MB - Storage: 16 MB NOR - Wireless: Atheros AR9531 (SoC) 802.11b/g/n 2x2:2, 1.5 dBi antenna - Ethernet: Atheros AR8229 (SoC), 1x 10/100 port, 802.3af/at PoE in - 4 user-controllable LEDs: · 1x power (green) · 1x user (green) · 1x lan (green) · 1x wlan (green) Flashing: TFTP boot initramfs image and then perform sysupgrade. Follow common MikroTik procedure as in https://openwrt.org/toh/mikrotik/common. Note: following 781d4bfb397cdd12ee0151eb66c577f470e3377d The network setup avoids using the integrated switch and connects the single Ethernet port directly. This way, link speed (10/100 Mbps) is properly reported by eth0. Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
Diffstat (limited to 'target/linux/ath79/image/mikrotik.mk')
-rw-r--r--target/linux/ath79/image/mikrotik.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/mikrotik.mk b/target/linux/ath79/image/mikrotik.mk
index ff3604f2fa..dccb05e45a 100644
--- a/target/linux/ath79/image/mikrotik.mk
+++ b/target/linux/ath79/image/mikrotik.mk
@@ -55,6 +55,14 @@ define Device/mikrotik_routerboard-lhg-5nd
endef
TARGET_DEVICES += mikrotik_routerboard-lhg-5nd
+define Device/mikrotik_routerboard-mapl-2nd
+ $(Device/mikrotik_nor)
+ SOC := qca9533
+ DEVICE_MODEL := RouterBOARD mAPL-2nD (mAP lite)
+ IMAGE_SIZE := 16256k
+endef
+TARGET_DEVICES += mikrotik_routerboard-mapl-2nd
+
define Device/mikrotik_routerboard-sxt-5nd-r2
$(Device/mikrotik_nand)
SOC := ar9344