aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/mikrotik.mk
diff options
context:
space:
mode:
authorThibaut VARÈNE <hacks@slashdirt.org>2022-05-02 17:07:45 +0200
committerDavid Bauer <mail@david-bauer.net>2022-05-21 15:45:33 +0200
commit03cfdf72e297c3b9c029bea847f0ff6d7dd3aa21 (patch)
tree371df89597d487948951fd0771027ebe154855fd /target/linux/ath79/image/mikrotik.mk
parent80baa6025940318602760deeb8a71560b6ae98bc (diff)
downloadupstream-03cfdf72e297c3b9c029bea847f0ff6d7dd3aa21.tar.gz
upstream-03cfdf72e297c3b9c029bea847f0ff6d7dd3aa21.tar.bz2
upstream-03cfdf72e297c3b9c029bea847f0ff6d7dd3aa21.zip
ath79: add support for MikroTik RouterBOARD hAP ac lite
The MikroTik RB952Ui-5ac2nD (sold as hAP ac lite) is an indoor 2.4Ghz and 5GHz AP/router with a 2 dBi integrated antenna. See https://mikrotik.com/product/RB952Ui-5ac2nD for more details. Specifications: - SoC: QCA9533 - RAM: 64MB - Storage: 16MB NOR - Wireless: QCA9533 802.11b/g/n 2x2 / QCA9887 802.11a/n/ac 2x2 - Ethernet: AR934X switch, 5x 10/100 ports, 10-28 V passive PoE in port 1, 500 mA PoE out on port 5 - 6 user-controllable LEDs: - 1x user (green) - 5x port status (green) Flashing: TFTP boot initramfs image and then perform sysupgrade. The "Internet" port (port number 1) must be used to upload the TFTP image, then connect to any other port to access the OpenWRT system. Follow common MikroTik procedure as in https://openwrt.org/toh/mikrotik/common. Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org> (cherry picked from commit 2bd33e8626bd04fd7115ee1a42aaf03aae2fffb8)
Diffstat (limited to 'target/linux/ath79/image/mikrotik.mk')
-rw-r--r--target/linux/ath79/image/mikrotik.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/mikrotik.mk b/target/linux/ath79/image/mikrotik.mk
index 30c1761134..869c466278 100644
--- a/target/linux/ath79/image/mikrotik.mk
+++ b/target/linux/ath79/image/mikrotik.mk
@@ -38,6 +38,16 @@ define Device/mikrotik_routerboard-922uags-5hpacd
endef
TARGET_DEVICES += mikrotik_routerboard-922uags-5hpacd
+define Device/mikrotik_routerboard-952ui-5ac2nd
+ $(Device/mikrotik_nor)
+ SOC := qca9533
+ DEVICE_MODEL := RouterBOARD 952Ui-5ac2nD (hAP ac lite)
+ DEVICE_PACKAGES += kmod-ath10k-ct-smallbuffers ath10k-firmware-qca9887-ct
+ IMAGE_SIZE := 16256k
+ SUPPORTED_DEVICES += rb-952ui-5ac2nd
+endef
+TARGET_DEVICES += mikrotik_routerboard-952ui-5ac2nd
+
define Device/mikrotik_routerboard-962uigs-5hact2hnt
$(Device/mikrotik_nor)
SOC := qca9558