aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/mikrotik.mk
diff options
context:
space:
mode:
authorJakob Riepler <jakob+openwrt@chaosfield.at>2021-12-09 12:12:37 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-02-07 00:03:27 +0100
commite0683839b8036388213d7662f3e0066a29b7d480 (patch)
treeb2a1b835fd48fac8e68e7c90ada355ed239638f9 /target/linux/ath79/image/mikrotik.mk
parentc32008a37b81d0ab1062993241a1e9f0a8e73102 (diff)
downloadupstream-e0683839b8036388213d7662f3e0066a29b7d480.tar.gz
upstream-e0683839b8036388213d7662f3e0066a29b7d480.tar.bz2
upstream-e0683839b8036388213d7662f3e0066a29b7d480.zip
ath79: add support for Mikrotik LHG 5
The MikroTik LHG 5 series (product codes RBLHG-5nD, RBLHG-5HPnD and RBLHG-5HPnD-XL) devices are an outdoor 5GHz CPE with a 24.5dBi or 27dBi integrated antenna built around the Atheros AR9344 SoC. It is very similar to the SXT Lite5 series which this patch is based upon. Specifications: - SoC: Atheros AR9344 - RAM: 64 MB - Storage: 16 MB SPI NOR - Wireless: Atheros AR9340 (SoC) 802.11a/n 2x2:2 - Ethernet: Atheros AR8229 switch (SoC), 1x 10/100 port, 8-32 Vdc PoE in - 8 user-controllable LEDs: - 1x power (blue) - 1x user (white) - 1x ethernet (green) - 5x rssi (green) See https://mikrotik.com/product/RBLHG-5nD for more details. Notes: The device was already supported in the ar71xx target. Flashing: TFTP boot initramfs image and then perform a sysupgrade. Follow common MikroTik procedure as in https://openwrt.org/toh/mikrotik/common. Signed-off-by: Jakob Riepler <jakob+openwrt@chaosfield.at>
Diffstat (limited to 'target/linux/ath79/image/mikrotik.mk')
-rw-r--r--target/linux/ath79/image/mikrotik.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/mikrotik.mk b/target/linux/ath79/image/mikrotik.mk
index 095a1cbc84..ff3604f2fa 100644
--- a/target/linux/ath79/image/mikrotik.mk
+++ b/target/linux/ath79/image/mikrotik.mk
@@ -46,6 +46,15 @@ define Device/mikrotik_routerboard-lhg-2nd
endef
TARGET_DEVICES += mikrotik_routerboard-lhg-2nd
+define Device/mikrotik_routerboard-lhg-5nd
+ $(Device/mikrotik_nor)
+ SOC := ar9344
+ DEVICE_MODEL := RouterBOARD LHG 5nD (LHG 5)
+ DEVICE_PACKAGES += rssileds
+ IMAGE_SIZE := 16256k
+endef
+TARGET_DEVICES += mikrotik_routerboard-lhg-5nd
+
define Device/mikrotik_routerboard-sxt-5nd-r2
$(Device/mikrotik_nand)
SOC := ar9344